Troubles with new 2.22.2

Updated today to latest stable 2.22.2 and since i updated i had all kind of instabilities on the rtk fix. On old 2.22.1 in same location we worked 10 days with never a problem.
I tried to reflash 2.22.1 but now the unit always goes in updater mode and wants me to update.
Isn’t it possible to revert to 2.22.1 without the unit going in updater after flash?

Can someone please tell me how to go back to 2.22.1 quickly?

2.22.2 gives all kinds of instability problems i have never had on 2.22.1
In the middle of the flight gps signal goes to zero, it never happened on 2.22.1, we are working in same location for the last 10 days.
Reach is connected to pixhawk using erb protocol.
All this on M2

Hi @corrado.steri,

We haven’t changed anything in the RTK calculation algorithm in v2.22.2, so this issue hardly can be caused by the firmware update. However, I’d like to analyze logs from this flight to check what may be the reason for the issue you experienced.

Would you mind sharing the following data from the M2 unit?

  • raw data
  • position data
  • base correction data

This guide describes how to get all the data from Reach.

There is no way to get back to the previous firmware version.

1 Like

Ok thanks


There is something wrong in the correction input, it looses it while in flight. Never done it on 2.22.1

We mounted another M2 we have on firmware 2.22.1 and no problems at all.

Have thrown the M2 with 2.22.2 in the trash bin from frustration, not usable since we updated.

Really do not understand why we can’t revert back to an old firmware version, i am not talking about 10 versions ago but at least the one before the latest, just for cases like now where there is an obvious fault somewhere in 2.22.2

I am not sending any beta tester data as you request unless you give us the chance to go back at least to the one before current release firmware.

Not giving the chance to go back at least 1 version is very stupid. In case you release a firmware with an obvious fault all people that update are grounded untill you do something…

1 Like

Before people from emlid answer with something useless here are the facts:

88 flights on 2.22.1 zero problems
25 flights on 2.22.2 problems on each flight
20 flights again on 2.22.1 zero problems

All flights at same location on same machine on sunny days with no wind.

These are facts from the field, rest in useless

Will update tonight with total number of flights.

At the moment my advice is DO NOT update to 2.22.2


This is your choice to provide us with data or not. We’ll take a closer look into your report anyway shortly and try to reproduce the issue.

I can understand your frustration but I am reminding you about our Community Guidelines. Would be great if you could read through it again. Please note, that further offensive messages not relevant to the issue discussion will be removed and your account will be silenced on the public section of forum.

1 Like

Answer with facts, word are useless when you let down people working like this.
In the mean time you look carefully where you broke the firmware please load 2.22.1 again so we can keep on working

1 Like

Nothing useful as usual.

Another 10 flights on 2.22.1 no problems to report.

Swapped to unit with 2.22.2, gps all over the place, doing an insane dance between single, float and fix

Tested same place, same drone, same antenna, just swapped units configured exactly the same

Both using an ntrip correction trough an onboard lte router

Please please, let we have 2.22.1 again until 2.22.2 is fixed

1 Like

Thanks for the tests, Corrado.

Early next week we will conduct our tests and work on pushing the fix if we confirm the behavior.

Sorry for the inconvenience.

Is there any future work that allows users to downgrade to a previous firmware, seems very very silly that this is not a option!!!


Hi Matthew,

In the future we’ll have this functionality.

In regards to the issue report with intermittent fix on v2.22.2, in the meantime we are looking into it. Will post updates shortly

Hey there,

We’ve conducted some tests with Reach M2 on the v2.22.2 firmware version this week. Reach M2 was getting corrections (GPS + GLO) from an NTRIP station in all the tests. We checked its performance in static measurements when Reach M2 was sitting at one place for 30 minutes, and kinematic measurements where it was moving with the speed of about 70 km/h.

In both cases, Reach M2 was maintaining a robust fixed solution.

I’d like to elaborate in a bit more details about the 2nd test. We attached Reach M2 and the GNSS antenna on a car roof. Reach M2 was connected to the mobile hotspot to provide it with corrections from NTRIP station.

Once Reach M2 obtained fix, we enabled log recording and started to move. We tried both to move faster and slow down. The max speed Reach experienced during the test was 70 km/h. As you can see from the screenshot below, Reach was keeping fixed all the time of the log (~ 5 min).

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.