Trouble connecting Reach RS2 to my WiFi

I’m having trouble connecting my brand new Reach RS2 to my WiFi.
I tried it on two different routers with WPA, WPA2 and without password, still can’t connect.
I have also tried hotspot on my mobile device, also without luck.

I am not new to Reach I have 3 Reach RTK, 1 Reach M +, 2 ReachRS and a ReachRS + which all work fine on the routes that the new ReachRS2 will not connect to.

I have charged the battery a whole night and it indicates that it is fully charged with light in all 5 LEDs.

I have tried from my tablet with ReachView and from a PC with browser on IP (windows7 and 10) and I can easily connect to the hotspot that ReachRS2 starts up and enter all WiFi information and save it, and then I can click on Connect and after that the WiFi LED on ReachRS2 changes from stable white to flashing blue and ReachRS2 tries to connect to the network and after approx. 30 seconds change the LED to bake to stable white.

I can log in to my router to see that ReachRS2 has got an IP address from the DHPC server but has not connected.

So what do I do now, should I send it back to you?

1 Like

You can send it to me, I’ll take it.


i have the same problem with this PicoStation M2 wifi antenna . but if I use a D-Link unit ,no problem . I still cant figure out what setting would cause that unit not to connect , but i have also seen if you try long enough it will slip in and the next time it will not :unamused: RS2 v2.20.4 and RS+ v2.18.1

1 Like

For sure

Hope ya get it fixed without having to put a stamp on it. But seriously, if you don’t, you know where to find me.


Emlid will get you fixed up! :stuck_out_tongue_winking_eye:

Probably just sleeping or partying late at night currently. :sleeping: or :partying_face: at the :clubs:

@ox3hi Do you a Ham Radio ?

1 Like

Hi Holger,

This looks weird.

Any chance you have an iOS/Android device nearby to run a Wi-Fi hotspot? Could you please try to connect RS2 to mobile hotspot? Please make sure you use simple SSID and password.

This is to check whether RS2 can’t connect to any network or to the network hosted by your routers only.

In the meantime, we’ll check what else we can try to resolve this.


Hi Dmitriy
I’ve tried my phone as a hotspot (Android) with the same result it doesn’t work.
Later today I set up a ruoter as a test with a very simple SSID and password.

Now it works
I set up a simple router with simple SSDI and password, and ReachRS2 could connect to this network and I update to Ver. 2.20.4 and after the update I could connete to my normal WiFi router, thank you for the comments.


This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.