Telemetry SIK radio

See attached picture for system info.

Just bought a SIK radio and trying to connect it. Problem is that i “lose” GPS when i connect SIK radios to my navio2 and introduce the -D switch. I never get fix, and gpshdop 99,99 and satcount 0.

And i got this message in MP (wich i think i never saw before): “GPS 1: detected as u-blox at 115200 baud” even though the serial is configured to 38400

The problem seems similar to this one: Telemetry outputs other than -A & -C don't work

/etc/default/arducopter options i use tried with:

TELEM1="-A udp:"
TELEM2="-C /dev/ttyUSB0"
TELEM3="-D /dev/ttyUSB1"
TELEM4="-E /dev/ttyAMA0"

#Options to pass to ArduPilot

-C is the SIK radio
-D is the teensy telemetry.
-E is the reach rover

GPS stop working when i connected the SIK radio and moved the teensy from -C to -D switch.

It works as it should with only the teensy on -C switch.

Edit: Can it be as simple as a powering issue? Atm the SIK is connected directly to usb, same for the teensy.

Hi Daniel,

Some 433 Mhz sik radios cause interference on the GPS module, I suggest to try powering radio separately.

aha, i do have a 433 Mhz… Do they cause interference because they are powerd by the rpi, or is it noise on the GPS signal? Any suggestion for shielding? I have sn-cu shield laying around?

Will it help switching from the usb interface to the 6p connector and a cp210x?

I’ve got remnoise of 75-85 with a mean of 78, and noise at 65-70.

I tried with the sn-cu tape around the SIK radio on the drone, but didnt improve gps. Tried shielding the navio2 gps antenna with a aluminium plate, but didnt help.

What is wierd is that the reach rover unit have OK signal with its shield (10 cm plate).

Another thing i noticed was that in MP under the “messages” tab this message popped up each 30 sec “GPS 2: detected as ERB at 38400 baud”. Usually it only show once each restart.

Have a look there:

I have Navio GPS, Drotek M8N GPS and 3DR 433 telemetry radio and good GPS with telemetry antenna looking down.


I have the v2 of the SIK radio with the usb interface. How did u connect the 3dr module to the navio2?

I will try pointing the antenna down.

Seems like you dont have shield on the navio2 gps. What satcound and hdop you get?


3DR radio is connected via USB to the Pi (-C /dev/ttyUSB0). I have 30cm USB cables.

2nd GPS is connected to UART and I2C (compass) (-E /dev/ttyAMA0)

No shield under GPS antennas, I have 15 to 19 satellites (GPS+GLONASS) with better Sat data on M8N at the end of the mast, HDOP below 1.


Tried with the antenna pointing down. It’s the same. 100 hdop and 0 sats on gps1, but reach rover is good.

Tried this as well. No success…

might i have gotten the wrong antenna length?

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.