Simple Quick Start method of TCP connection gives Connect Error (111)

High guys, I have two emlid reach RTK I am trying to use. Today 4/17/18, I reflashed the latest firmware 2.9 and updated the receiver and reach view to 2.11. I went through the quickstart and had both planes connected to my wifi network 10.... I set the base station as the server port 9000 address is localhost which I cannot change. the Rover corrections input is the TCP client port 9000 with the base’s address, 10.... On the follower corrections input tab, it just get stuck at Connecting… then Connect error (111) over and over again. Both base and rover modules have a solution status of Single. I also tried BlueTooth and they were able to pair but always had the address underneath, never said connected. I then tried to apply the rtks to my application, which is to get it running on the Pixhawk with PX4 Firmware. I set the corrections input and position output on the rover module to serial UART, both ERB and NMEA formats. I then connected the base module to my laptop running latest QGroundControl using serial USB-to-PC and couldn’t get that to work. Nothing is working for me, Please help!

1 Like

Hi Patrick,

Is your base station also connected to your Wi-Fi network?

1 Like

You can connect your phone to the network and scan with our phone app.

Yes, both the base and the rover are connected to the same WiFi network and I am inside reach view so I know both their IP addresses.

Please provide a system report for both devices so we can take a look at the settings.

Base-SystemReport.zip (62.2 KB)
RoverSystemReport.zip (62.4 KB)

Here are the full system report for both base and rover

Seems ok to me…What kind of network do you use? Is there a chance communication of the devices between each other is forbidden? I’ve seen some Wi-Fi networks with special security which prevented two Reaches to communicate with each other.

I’ll try on a different network…but why wouldn’t the bluetooth connection work? I get paired by not connected, and it gives a recv error (111). Also, I need to get this working with a Pixhawk and QGroundControl, but wanted to verify the reach modules are working first by either TCP or bluetooth. Any advice on what to try next?

I am having the same problem using this Quickstart but I am using RS models, so I can use LoRa, but want to try TCP option with Port 9000:
https://docs.emlid.com/reach/quickstart/

Maybe Port 9000 has to be opened up on your end through firewall to work?

Did you get it to work?

I was never able to get my emlid reachs to work, not over tcp, bluetooth, uart, no luck.

Sounds like you have some faulty Emlid(s) or just wrong settings altogether. There definitly is a learning curve, but after 2 weeks of excessive reading and great help from the forum here, I’ve gotten much further than I thought I would. It’s pretty easy overall “once” you get the hang of it, but yes, it’s rather tough “tweaking” with so many settings…but you kind of need that and to know how to “tweak” things beyond the “default” to customize to your needs.

AT the very first, I used BT no problem connecting to Android Note 8 and to a Trimble Nomad 900G (to MicroSurvey FieldGenius and Layout; but still cannot get SatViewer and TerraSync to BT to Emlid Reach RS Rover using Port 8 or 9 from Data Collector built in Port 2 GPS).

Connect via LoRa works fine.

Tried TCP, seems to work but really don’t use that during testing yet…I didn’t have to port forward port 9000 after I tried again on a desktop reachview.

Also tried using “free” rtk2go.com via NTRIP. Seems to work.

Haven’t tried serial, but that should be the most straight forward of all of them I would think?

Something may be up with the communications portion of the units?

you will definitely get that UNITL another device CONNECTS via BT to get the data to it.

i.e. when I use my Trimble Nomad 900G, when Reach RS Rover connects to it via BT, then recv error (111) obviously goes away… when I disconnect Nomad, error again…that is normal.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.