Setting up a correction link - Arducopter integration?

Hi Fred,

I’m afraid we don’t have an exact picture of the setup. However, there should be no issues with the integration. We have a special cable for integration with Pixhawk 2.1. You can use this scheme as a reference. Pixhawk Cube ports’ pinout is available in this overview.

Please test your setup without enabling the RTK inject function. Also, I’d ask you to make sure in the ReachView app that the receiver has a good satellite reception is capable of providing at least Single solution stably.

Please keep me informed of your test results.

Hello,
this are my settings and my results. No signal on GPS2 port on the orange cube.



reach M2 Settings:

Mission Planner Settings:

Hi Fred,

Thanks for the screenshots!

I can see there are no corrections coming to the Reach M2 as well as no position is transmitted to the autopilot. It seems like there is indeed an issue with the wiring of the ports.

We’ll try to reproduce your issues to check what could be changed with the setup. We’ll reach out as soon as there’s news. We’re still working remotely so gathering all of the required equipment might take time.

which screenshot you mean exactly?
Do you need my parameter file from Mission Planner?

Hi Fred,

Can I ask you to send some pictures of your setup? It’ll help us exclude issues with wiring.

Thanks!

Dear Mikhail,
here is my cable connection:


I have connected a separate power source to pin 5 V and ground. The Reach M2 module also starts and can also be accessed with Reachview.
In addition, I also tested the original connection cable from EMLID, also the same result, no GPS signal on the GPS2 port from Pixhawk.

But I get GPS injection signal in.
If you wish, i can send you Mission Planner settings file.
Thank you very much.

Hi Fred,

Do I understand correctly that if you are powering an M2 separately your Orange Cube does receive corrections?

It seems, that Pixhawk cannot provide enough power to M2 via a GPS2 port. In that case, I would recommend powering Reach M2 separately using a micro-USB cable or by connecting 5V and GND pins to a separate power supply as you did.

1 Like

the module was fed separately with 5 volts all the time with an separate power supply and I don’t get any signal in at the GPS2 port.

i´m using a separate power supply with an micro USB connector on the side of the M2 module.
The module is working and the injections too.
Please send me all needed Mission Planner parameters for the pixhawk cube orange and the needed parameters/settings for the M2 module
I´m trying since weeks without any results.
And i´m wondering why EMLID doesn´t publish connecting specifications in the docs for the reach M2 module?

Hi Fred,

We are trying to reproduce your issue at the moment. Once we get any results, we’ll definitely let you know.

If you need Reach M2 connection specs, you can find it in the pinout section.

Hey Fred,

Can you, please, take a picture of your Orange Cube connected to the M2?

Hello,
as i mentioned in the past, i have connected it with this cable, but without the red wire, this wire i have removed this is the +5V power pin. The power 5V cames from a stabilized module direct on the micro USB plug on the side of the M2 module.



Can you tell me what settings i must use on in reach view for the m2 module and what settings are necessary for the pixhawk orange cube?

Same issue here and havent found any solution on this “support” forum. Have you managed to make it work?

Same here, I just purchased a set of Emlid M2 and RS2. Follow every single step, in this thread and I get the same error. GPS 2 failing configurations check.

I can see corrections in mission planner, I tried not using corrections. I have tried changing the output to ERB in both mission planner and the M2 (failed)

I just can’t get to make mission planner to recognize the M2.

frustrating and we have to do a job next week.

If I can work with you guys on getting this to work please let me know what else I can provide. LOGS, DETAILED PICTURES, PARAMETER FILES.

Anything to make this work.

Thanks

how do have connected the first GPS?
Trough UAV CAN or with serial?
I had connected my first GPS (Here 2 Antenna) at the beginning with the UAV CAN Bus and i doesn´t works.
After that i had changed the parameters and the antenna cable connected via serial (I2C) and than it works.
It seems that the Cube cannot handle two different types of connection.
Both connection setted to serial and i got two signals from GPS 1 and GPS2
GPS_TYPE2 = 5 (NMEA) wrong
GPS_TYPE2 = GPS - OK
Good luck!

how do have connected the first GPS?
Trough UAV CAN or with serial?
I had connected my first GPS (Here 2 Antenna) at the beginning with the UAV CAN Bus and i doesn´t works.
After that i had changed the parameters and the antenna cable connected via serial (I2C) and than it works.
It seems that the Cube cannot handle two different types of connection.
Both connection setted to serial and i got two signals from GPS 1 and GPS2
GPS_TYPE2 = 5 (NMEA) wrong
GPS_TYPE2 = GPS - OK
Good luck!

Thanks for pointing this out, I will give it a try and will confirm if it worked for me.

Checked and Passed so far :slight_smile:

@rcdevil Thanks again to point that connection issue. I was lazy about making that change, but it does makes sense.
If you are using the HERE2 GPS Unit you MUST use (i2c). If you are connected with UAVCAN you pixhawk will not recognize the M2 as you second GPS unit.

Configuration that worked for me.

Reach M2:
Only used to wires from port S1to pixhawk port GPS 2 (pin 5 RX to pin 2 TX, pin 4 TX to pin 3 RX)
And power M2 from the same port S1 pins 6 (5v) and 1 (Gnd) to the servo rail in the pixhawk. (any available, assuming you are using a 5v BEC to power up your servos).

Correction Input
DEVICE: UART
BAUD RATE: 38400
FORMAT: RTCM3

Position Output
DEVICE: UART
BAUD RATE: 38400
FORMAT: ERB

Pixhawk Params:

GPS_AUTO_CONFIG=1
GPS_AUTO_SWITCH=1
GPS_INJECT_TO=1
GPS_TYPE=1
GPS2_TYPE=13 (ERB)
SERIAL4_BAUD=38
SERIAL_OPTIONS=0
SERIAL_PROTOCOL=5 (GPS)
Save params, reboot pixhawk and it will auto detect GPS 2 as RTK float

1 Like

Hey there,

Thank you all for the valuable suggestions!

We have conducted the tests, so below are the settings that need to be applied for Reach M2 and Pixhawk Orange Cube configuration. They change regarding the Pixhawk Orange Cube’s port and M2’s output format you are using for the connection:

SERIAL3_BAUD or SERIAL4_BAUD must be set equal to the receiver’s position output baud.

M2 ERB output via GPS port

  • GPS_TYPE = 1 (AUTO) / 13 (ERB)
  • SERIAL3_PROTOCOL = 5 (GPS Output)

M2 NMEA output via GPS port

  • GPS_TYPE = 5 (NMEA)
  • SERIAL3_PROTOCOL = 20 (NMEA Output)

NMEA baud should be equal to the baud of PC-Pixhawk connection or greater.

M2 ERB output via Serial4/5 port

  • GPS_AUTO_CONFIG = 1 (Enable)
  • GPS_AUTO_SWITCH = 3 (for only one GNSS module) / 1 (to use one of two modules with best readings)
  • GPS_TYPE2 = 1 (AUTO) / 13 (ERB)
  • SERIAL4_PROTOCOL = 5 (GPS Output)

M2 NMEA output via Serial4/5 port

  • GPS_AUTO_CONFIG = 1 (Enable)
  • GPS_AUTO_SWITCH = 3 (for only one GNSS module) / 1 (to use one of two modules with best readings)
  • GPS_TYPE2 = 5 (NMEA)
  • SERIAL4_PROTOCOL = 20 (NMEA Output)

To send the raw data MAVLink packets to specified GPSes:

  • GPS_INJECT_TO = 0 (for GPS port)
  • GPS_INJECT_TO = 1 (for Serial 4/5 port)
  • GPS_INJECT_TO = 127 (for both)

We’ll think about how we can add all of this information to our guide.

1 Like