RS2+ waiting for corrections

When I say “rover”, I’m referring to the Mavic 3E in your case.
It may be on the Mavic 3E RTK module side of things. You may have entered the NTRIP IP and port stuff correctly but perhaps something isn’t enabled via the RC PRO interface. I’m awaiting receipt of my RTK module. Did it come with configuration instructions for the RTK via the RC Pro gui?

So the base output is on and set to local NTRIP

can you show an image of the wifi screen on the RS2+ and an image of the NTRIP credential screen on the M3E?

Hello everyone. I was able to figure out the problem. The IP address you need to enter in the Drone RC changes from when both the receiver and phone/tablet with Reachview 3 app are connected to WIFI. When you put the receiver into hotspot mode that IP address changes. You need to input the IP address displayed under the local NTRIP setting while the receiver is in Hotspot mode in the DJI RC RTK settings tab.
Reach RS2 RTK plus and DJI Mavic 3 Enterprise RTK setup guide 22.11.9.pdf (7.6 MB)

Peter, Peter, Peter… I told this to you earlier. I’m glad you got it working, but next time you might save yourself some grief if you actually read…!

Good luck!

1 Like

You were right Dave, but being a complete rookie the terminology and settings were a challenge to understand. I had the IP address from the settings when the Receiver was connected to wifi entered identically in the RTK settings on the drone. The problem was when the receiver was put into hotspot mode that IP address changed. I had to have checked that 25 times-but only when in the office connected to wifi. The whole initial process when viewed from an inexperienced outside perspective could use some better documentation.
But-thank you for the correct suggestion! It was that lead that had me check those settings in the field and that was the key.

This stuff is extremely particular. You can’t be just close and have it work. Settings need to be set precisely. Unfortunately, error messages are often of no help to determine exactly where the problem lies. “Check the IP at each start up for correctness” is not too complicated, just sayin.

Okay, lecture over. Go learn and have fun!

Well, I have to disagree on the root cause of the issue. The answer is in this picture:

We can see that the controller is connected to the base station stream, so it is not an issue with networking or IP addresses. The number of satellites on the base and the position of the base are clearly visible. So what could be the reason?

If you look closely at the Latitude field, it is 50.xxxx for the aircraft and for the Network corrections. But we know that the base is just 10 feet away!

The aircraft is not able to use the corrections and produce a fixed solution because there is a typo in the base station position.


I think I did not have the base setting for the manual point I was setting up on correct.
The value on the aircraft position was being received by satellite- the other value was the incorrect value I had input, being sent from the Receiver.
When I double checked that I had the base mode in manual and the coordinate for the known point I was set up on was correct I had these results:

1 Like

I think there were different issues on different days.

1 Like