RS2 version 26 acting bizzarely

Ok so the reach keeps on turning on bluetooth by itself, and is running real slow

I have to continually force refresh my browser to stay connected / drops connection

It popped up an Emlid privacy page I clicked ok, but now i can not reload at all after
I can still ping its ip through command prompt, but no browser page, very odd.

blue tooth just keeps flashing then turning blue like it is connecting then disconnecting. though it should not be on at all

Will try reboot, if not reflash

After restart the emlid loading screen is slow and is a blue solid bar.

tried to turn bluetooth off, the rs2 is down for the count again re flash it is

Ok after the reflash everything seems to be nomal again.

Nope was good for a little bit but now its playing bluetooth games again and locking up.

Any ideas what could be causing this Emlid?

The heat sink is very hot, It has not run like this before I maybe have 48hrs on this unit.
I have generated a full system report, where do i send it @tatiana.andreeva.
will try a pm.

Unit has been flawless until now.

Seems the common denominator with firmware 26 troubles are Bluetooth? (not just RS2)

Seems it needs a good look at.

I do not use Bluetooth for anything, I always leave it turned off. But the RS2 is deciding on its own to turn it on.

This is not a high hour unit, one 24hr ppp, plus playing with it so maybe 48hrs total. It was on version 26 for the 24hr PPP.

this is the first real issue i have had with it.

Anyone know how to log processor temperature?

After a full overnight cool down the RS2 functions as normal again, I am logging temp manually to see when/if the RS2 locks up again.

The RS2 temp last night was 45C. I have also measured a M2 running at 52C without issue on previous firmware. But what changed last night vs today?

The first time I used the RS2 for 24hrs it was -1C outside so it stayed very comfortable.

Hi @PotatoFarmer,

We’ve got the Full System Report you sent to the support email, thank you! We’ll check what could be causing the issues you faced.

Do I understand correctly that you’re referring to the LED status of the unit?

Yes, the status light.

But also in the web browser the blue tooth was always green. But now i see that may have been because of the unit freezing. Both wifi and hotspot the interface would freeze.


Thanks for the specification!

I just wanted to note that the LED status of the Reach RS2 doesn’t show the behavior of the Bluetooth. The connection LED shows the state of the RTK solution:

  • when it turns blue, it indicates that the unit transmits corrections;
  • when it’s blinking white, it shows that the unit calculates either Single or Float;
  • when it becomes solid white, it means that the unit obtained Fix.

All of these statuses are described in our LED status docs.

We’re currently checking what could be the cause of such behavior. I’ll give an update once there’s news.

I tried as scientifically as possible to make the RS2 lock up again. Turning on each function then waiting 15min taking a temp then turning on another function.

It took many hours, but the hottest I could get it even with charging was 43C and everything enabled. I have found it is slightly warmer in kinematic vs static mode. But no problems with interface or connection at that temperature.

The night it locked up the reach surpassed this temperature within minutes of it turning on.
It is possible i fixed something then by re flashing but it took time for the component to cool back down.

1 Like

A post was split to a new topic: Reach RS+ RV3 access

Hi @PotatoFarmer,

How is it going? I just wanted to tell you that we have released the 26.1 update that should resolve the disconnection issues with ReachView 3 app. Please update your receivers to check if the update works for you.

The full list of fixes and improvements is available in the community forum thread.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.