RS2 rover losing fix when out of sight of base station

LORA’s are line of sight. You may be too close to the obstruction that’s blocking your line of sight. Or its possible another radio transmission is stomping on yours, if it’s close enough frequency with enough wattage you’ll get drowned out, especially the further you get from your base.

Is your antenna touching the tripod?

LORA is not line of sight. Who would buy one if you had to stay in sight. You would just use your total station. That said i regularly push out 2000 to 3000 foot in the woods if it is relatively flat. I also use an aftermarket antenna that helps tremendously.

My non expert opinion is its a hardware issue with certain units containing similar but different components.

1 Like

Have you tried putting ver 27 back on?

In contrast to line-of-sight propagation, at low frequency (below approximately 3 MHz) due to diffraction, radio waves can travel as ground waves

Lora is 900Mhz it is very line of sight, just by the fact it is 900Mhz.

Emlid also gives there usable distance as line of sight.

Who would buy one? Lora’s niche is distance at a extremely low power requirement. They allow low data levels to be transmitted over far distance using very little energy.

This low energy transmission also allows the transmitter to be classified as non licensed in the 900Mhz band in most countries. This is because it has little potential to create interference with higher powered licensed radio emitters working within the same spectrum.

Another troubleshooting step is pick only one constellation at the lowest data rate. If you try to transmit too much data at a low rate it will clip and you will drop the transmission all together. At the highest data rate you move more data at the penalty of lower distance.

If you would like to learn more about radio propagation check out amateur radio club meets in your area, and become a licensed amateur operator.

Cheers VE6TFD

5 Likes

A post was split to a new topic: Reach RS2 LoRa range decreased significantly

No, it doesn’t seem like I can download older firmware. We have encountered the same issue with another set of units operating on v26 though. Both bought recently and so I am leaning towards a possible hardware issue?

No

As I’ve said previously, we have performed surveys on these sites without any trouble for over a year. Overnight, this problem has developed across multiple sites which is covered by the engineer using the same equipment, firmware and settings. The sites are dotted all across the north east of England and therefore it is not a localised issue. A new set of units have been supplied to the engineer, using the same settings and firmware and everything is working fine.

There seems to be a problem with this pair of RS2s.

Hi Dave,

According to raw data files received by email, both base and rover are affected by some strong interference or placed under an obstructed sky view. Take a look at them:

There are many red bars which mean cycle slips. There are also blue and red strings that show low SNR values. Overall, it shows that the raw data has a poor quality which may be caused by the reasons mentioned above.

Furthermore, take a look at these base correction logs:


These gaps mean that the base stops sending corrections in these periods.

You can establish the connection between the base and the rover over NTRIP via Emlid Caster to check whether this issue is related to environmental conditions or the receivers itself. You’ll face the same issue if there are interference sources or obstructed sky view. If not, the connection will be stable and the rover will not lose the FIX solution on a long baseline.

If you’re entirely sure you don’t face this issue with another Reach RS2 in the same conditions, please send us the logs from them recorded in the same place. I’ll examine them and compare them with the logs from the units that bother you.

2 Likes

Hi Kirill,

Many thanks for analysing those logs. If I am able to, I will repeat this for another set of RS2s in the same conditions tomorrow and send you the logs.

3 Likes

Great! I’ll be waiting for them.

1 Like

Hi Kirill,

I repeated the same test with a new set of RS2s and did not experience any problems, using the same settings and setting up the base station in the exact same location and I followed the same path with the rover unit and then walked further.

The log files have been emailed to you

1 Like

If they receive anymore logs on this issue they could start a bonfire

2 Likes

Hi Dave,

I received those logs from Liam, thank you for that!

It may require a bit more time to check them out, but I’ll get back to you as soon as I accomplish.

Hi Dave,

Thank you for your patience!

The last raw data logs you sent are indeed of much better quality in comparison with the pair you’ve reported.

In the Full system reports, I couldn’t find any signs of LoRa malfunctioning. But I agree that another pair shows completely different results in the same area. Maybe the root of this is in something else.

Another thought confusing me is that it is very unlikely that two devices start to behave that way without any apparent reason. To narrow it down, I’d test the receiver from the misbehaving pair with the receiver from the well-working pair. There will be two tests since there are two possible malfunctioning devices. It’ll show which one. It can be performed in another place if it’s more convenient to you.

I have followed your advice. I carried out another 2 tests. The first test was using the base unit from the set which worked previously and the rover unit from the set which had issues. There were no problems.

The 2nd test involved the base unit from the set which had issues previously and the rover unit from the good set. The same problems occurred, so must be an issue with the base unit.

All the necessary files have been emailed to you for analysis.

Seems to me like there’s a hardware issue with one of the units?

1 Like

Hi Dave,

I received the logs via email. Thank you for them!

It may require a bit more time for analyzing. As soon as I accomplish, I’ll reply to you in this thread.

Hi there,

We had a conversation with Dave’s colleague over email, and I’m here to share the results. The last test helped us a lot. The issue turned out to be hardware-wise. We localized the malfunctioning unit and decided to replace it.

If you experience any issues with LoRa, please reach out to us via email or create a new topic. There may be a lot of different reasons, from settings to hardware issues. Each case should be considered separately, and we’re always here to help.