RS2 rover losing fix when out of sight of base station

Before creating a new thread please refer to Quickstart guides for Reach and Reach RS.

In case you are creating a thread about an issue please specify the appropriate sub-category first!

Recently, I am having trouble with my RS2 units when carrying out a RTK survey. As of last week, when moving out of sight of the base station, I lose a fix solution with my rover unit (using LoRa). Distances that this has occurred at have ranged from 60 - 200m.

I am running the firmware 28.4 on both units and have not changed any settings from previous weeks/months when I have had no issues. This issue seems to have appeared over night.

I have used Android and iOS devices, using reachview 3 app and through the web browser.

Any ideas?

Hi Dave,

What are the LoRa parameters on both base and rover side ? Frequency, air rate, power ?
Is that happening on a particular site or anywhere ?

Hi Florian,

Frequency is 868.0 Mhz, Air data rate is 9.11kb/s and power output is 20dBm.

I have also tried other frequencies within the permitted range and air data rates.

Unfortunately this is happening everywhere now, in places where previously I have had no issues at all.

1 Like

Hi Dave,

Check the antenna connector, any chance that it got damaged? Try not to install the antenna at all, do you get the same range? If yes, then the antenna or the connector is broken.


I have checked the antennae and connections for both units and they all are in good condition.

I shall carry out the test which you have suggested

1 Like

Hi Dave,

The LoRa range issues are usually related to environmental conditions. If both base and rover are placed in the line of sight, but the issue persists, we’ll need to check the following logs:

It’d be great if you recorded logs during the test suggested by Igor. Furthermore, the Full system reports from both units will be of help.

Since there can be a sensitive data, you can send this info to


When you say out of sight, what do you mean?

What causes you to lose line of sight?

Lora can get impressive distance if unobstructed, but its a fairly weak signal. Water really degrades radio signals, so lush vegetation, rain, fog can all stop signals as well.


See my earlier thread and others on this topic.
It all started with one of the 28 upgrades. For me reverting back to 27 fixed it. One of the other posts had a possible fix but i have not tried it out yet.

This reply from Emlid was all I got. They see the same problem but never came up with a fix.

"In your case, we can see such delays on short baselines too. We’ve caught a similar behavior in our office. We’re checking the firmware to find possible reasons for such behavior and testing solutions.

At the moment, our tests showed that possible delays of correction messages that can be created from the software side are infrequent and not consistent"

1 Like

Thanks for this. I’ve spoken to our engineers across the country and some seem to be fine with the latest firmware yet others are experiencing these problems. It doesn’t make sense. Speaking to one engineer, he had the exact same issue when using firmware version 26 and now he has been supplied with replacement units running 28 and its working fine. Replacement antennae didn’t solve the problem either.

In this case, we’re having the exact same issue with 28. So the firmware version doesn’t seem to be the common cause. This also seemed to have occurred overnight without any changes in equipment or firmware. I’ve asked for the engineer having this problem to try firmware 29 beta.

1 Like

I mean out of direct line of sight. This has never been an issue in the past. There has been no lush vegetation, rain, fog etc

Hi Dave,

Thank you for your patience!

We can’t merge all issues related to the low LoRa range and give them a particular reason. We consider each case separately since the reasons for such behavior can widely vary depending on many factors: terrain, firmware, interference sources’ presence, and so on.

In your case, I’d recommend you restore the initial settings on the base and the rover. You can do it in the General settings tab as shown in the screenshot below.

Then, configure the receivers according to this new video.

Furthermore, you can lessen the air data rate by switching off some RTCM3 messages in the Base mode. It may help you to extend the LoRa range as well.

Did you have a chance to record the logs I asked you for and send us via

I have tried the above. I have also reflashed each unit to firmware version 28.4. I am still having the same issues. I lose a fix approximately 100m from the base station at our offices where we have conducted numerous surveys prior without any issues.

I have replaced the antenna for each unit and have also swapped the units around between base and rover (basically trying anything I can think of).

I have just tried 2 new units with the same settings and had no issues with getting a fix on the rover unit. I will send you and email containing the log files from today.

This is starting to affect our work for our customers now and I would appreciate it if we can find a resolution to this as soon as possible.


LORA’s are line of sight. You may be too close to the obstruction that’s blocking your line of sight. Or its possible another radio transmission is stomping on yours, if it’s close enough frequency with enough wattage you’ll get drowned out, especially the further you get from your base.

Is your antenna touching the tripod?

LORA is not line of sight. Who would buy one if you had to stay in sight. You would just use your total station. That said i regularly push out 2000 to 3000 foot in the woods if it is relatively flat. I also use an aftermarket antenna that helps tremendously.

My non expert opinion is its a hardware issue with certain units containing similar but different components.

1 Like

Have you tried putting ver 27 back on?

In contrast to line-of-sight propagation, at low frequency (below approximately 3 MHz) due to diffraction, radio waves can travel as ground waves

Lora is 900Mhz it is very line of sight, just by the fact it is 900Mhz.

Emlid also gives there usable distance as line of sight.

Who would buy one? Lora’s niche is distance at a extremely low power requirement. They allow low data levels to be transmitted over far distance using very little energy.

This low energy transmission also allows the transmitter to be classified as non licensed in the 900Mhz band in most countries. This is because it has little potential to create interference with higher powered licensed radio emitters working within the same spectrum.

Another troubleshooting step is pick only one constellation at the lowest data rate. If you try to transmit too much data at a low rate it will clip and you will drop the transmission all together. At the highest data rate you move more data at the penalty of lower distance.

If you would like to learn more about radio propagation check out amateur radio club meets in your area, and become a licensed amateur operator.

Cheers VE6TFD


A post was split to a new topic: Reach RS2 LoRa range decreased significantly

No, it doesn’t seem like I can download older firmware. We have encountered the same issue with another set of units operating on v26 though. Both bought recently and so I am leaning towards a possible hardware issue?