RS2 no lights, unresponsive after FW update and discharge

Hi Folks

Updated one of my RS2’s yesterday to stable 2.20.8. Following, the update I left it alone to reset and went out of the house, completely forgot about it. I must have left the battery fully discharge…

Anyhow I tried recharging overnight (no lights) and as of this morning still no lights at all, and the unit is only drawing 0.125 amp from the charger. I checked re-charge with my other (good) RS2 and as soon as I plugged it in, it began to draw 2.5 amps from the charger almost immediately and the charging light sequence came on

So to summarise, no light sequence, unresponsive and only drawing 0.125 amps on the charger…

Any idea what’s going on with it?

Have you tried to reflash from the computer?

https://docs.emlid.com/reachrs2/common/reachview/firmware-reflashing/#flashing-process-for-v2208

Cheers. No joy. Not recognised at all by the laptop/re-flasher.

However following this, I connected it back to the charger and it’s now drawing more juice around 0.375 amps according to my USB power meter. Maybe it’s just super deeply discharged…

Anyhow here’s hoping it’s not bricked.

Update: it’s back!!

Left it on the charger for another 40 minutes or so, charging away lowly @ 0.38 amps, with absolutely no lights or any signs of life. Then disconnecting it and leaving it for a few hours. Having reconnected it to the charger once more… hey presto - suddenly lights, camera action! Also now charging at a far more substantial 2.31 amps.

Back into ReachView on the unit, (battery SOC was errrr 2%) and it said the 2.20.8 upgrade was available…strange that as I’m fairly certain that had already been instigated and rebooted yesterday.

Perhaps that was part of the issue…I can only surmise it either was super deeply discharged and possibly also in a weird loop between the firmware update!

Anyhow It’s back and all good and I can rest easy I haven’t bricked it!

1 Like

Hi @DirtyHarry,

Glad to hear the unit works fine now!

May I ask you to send me the Full System report from the device in PM? I’d like to check if there is anything unexpected in it.

Will do. :smile:

1 Like