RS2 losing RTK correction, rover reboot helped


I have two RS2s, one as a base and the other as rover. I got them working nicely, set the base coordinates manually and achieved appr 6 cm height accuracy on the rover. Correction input is LoRa, positioning mode Static.

This worked for some days, but suddenly the Solution status dropped from Fix to Single. Reachview was still displaying the RTK parameters / Age of differential and Baseline and the Base position correctly.

I first tried to reboot the base, no effect. Then I rebooted the rover (from ReachView/Settings), this solved the problem. When the rover rebooted, the Solution status went from Single to Float to Fix.

Also the rover’s SNR bars improved after the reboot.

What went wrong, how can I keep this from happening again? It seems like a HW/SW issue since a rover reboot solved the problem.


Hi Antti,

I believe that the reason for such behavior may be the Static Positioning mode. The thing is that Static allows maintaining the Fixed solution only if you keep the unit unmoved on one point. Once you go to another point, the receiver may lose the solution.

I suggest you check the Kinematic mode instead. It would be great to know how it works for you.


The rover hasn’t been moved, but I will see how Kinematic works.



Which firmware version is installed on your RS2 device?

If the same behavior persists with Kinematic, the following data will be of help for further investigation:

  • raw data, base corrections, solution logs from the rover
  • raw data log from the base

Before you record them, please enable the Raw data debug option on the Control panel (gear-shaped button).

Keep us posted!


Is the device firmware version in the top right corner of ReachView? It says v2.24.2.

I will enable the loggings on both units, also the Raw data debug. Then I’ll just wait for this to happen again.

By the way, in my target application the rover will only move some 20 m in lat and long directions, and maybe 3 meters in height. Movements will be slow, I’d say maximum is 2 m per 24h in each direction. Should I be using Kinematic or Static, which will give better accuracy and reliability?



In such a case, it is better to use Kinematic. Both these modes are reliable and provide you with centimeter-accurate results in RTK.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.