RS2 issue with mobile data sharing

Here is the timeline of the problem:
1.Emlid flow v.8.5 and RS2 fw29.+ was working fine with Android
2.The RS2 was in my colleagues working with IOS
3.After connecting with Android device, a problem with WiFi was fixed. The WiFi connection was visible for few seconds and was impossible to establish stable connection.
4.The Emlid Flow app was updated to 8.6, the RS2 firmware was flashed to v30.1.
5. The problem was the same. The only possible connection was Win10 PC via WiFi. I was trying different settings. The only one working solution was to disable the : Mobile data->Share mobile data from Reach in hotspot mode. When the setting is disabled, the WiFi connection works fine for all my Android controllers.
6. I started to try with different Sim cards from different Operators, the result was the same.

The solution is temporary. In this situation the CORS corrections are working well with the SIM in RS2, but the background map in the controller is not updating even with activated mobile data from sim card in the controller.

Hi @ffcb,

Thanks for reporting!

Just to ensure I understand the issue correctly: when your Android is connected to the RS2 internet hotspot from the SIM card, the connection frequently drops, right?

When the “Mobile data->Share mobile data from Reach in hotspot mode” is enabled, it is impossible to connect any android device via WiFi with RS2.

Thank you in advance.

Hi Ivan,

Sorry for the delayed response!

Can you please generate a Full system report on your receiver and send it to I’ll check what could be the root cause here.


I just wanted to confirm that I received the Full system report. I’ll get back with the news once I check everything.

Hi Ivan,

We checked everything with the devs. Indeed, there can be an issue with an unstable hotspot connection when the internet is shared from Reach. At the moment, we’re still investigating this behavior as it’s quite hard to reproduce and find out what exactly causing it.

Once there are any updates about this, I’ll let you know. For now, it seems that it’s better to use alternative methods to share the internet connection with your mobile phone.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.