RS + does not maintain good SNR

I have 2 Reach RS + units. Both units worked great off the start but now neither of them maintain good SNR. I will start out with a number of satellites in the green, in fact most of them. Within a minute or two they will start going to red and jumping in and out as red, green.
I cannot get a fix or even float status.
thanks for any help

Can you post the following things:

  • raw file (ubx)
  • images of your environment where the raw file was collected
  • images of the unit itself, when it collected the data.

Then we can take a look.

Will do. Ill set up and go through with the base, where I set up one week and things were fine. The next week, over the same control I started having trouble not getting high enough SNR. I also set up both in the field next to my house a couple times with same result.

Hi @lonottosen,

I agree with Christian. To understand what causes the issue, we’ll need raw data logs and photos of your setup and environment. Please keep us posted.

1 Like

I set up this morning and tried to obtain a fix with one unit. I have included a photo of the setup and landscape where I was collecting data.
I also included logs. Let me know if I did not post the correct information.
thanks for any help.

Can you upload the ubx file as well?

It is not allowing me to upload attachments as I am a new user.

Just upload to a file-service like we-transfer or the like.

I emailed the UBX to your info dronographica email.
I am new here and could not figure out how to do it another way. Sorry if that is inappropriate way to do so.

Ok, figured it out. I am a bit slow tonight I guess…

LInk to UBX https://we.tl/t-PZAT9fOGva

Thanks for the logs!
Did you move or cover the unit around the 15:05 time mark ?
Lots of signals seem to suddenly loose some SNR…

No I did not cover of move the unit. Any thoughts on settings or other things I can do?

I haven’t looked at the files etc yet, but 1 thing I would definitely do is get the BASE higher. Add an extension to your tripod. I.e. 1’ to 2’ or so. It lets you also get the LoRa antenna vertically pointed down.

Also, try using BEIDOU instead of GLONASS to see if that helps.

Send your SIMPLE REPORT also.

Environment looks ideal… unless something with huge ElectroMagnetic Interference or High Voltage Power lines out of frame we don’t see.

1 Like

That is a good idea. Ill check into an extension.
The odd thing is I set up on a point and everything was working great. A few days later and ever since I have not been able to obtain even nail down “float”.

Another question I have is one day I set up my base and input coordinates manually on a known benchmark. Oddly enough I had my rover about 50 to 70 meters from the base and the baseline readout was 7800.00 or so meters. Over 7000 meters baseline when I can see the unit?

You can’t get a fix with one unit. Did you have a live connection to a base station somewhere? Or did you download some base station files to process against?

3 Likes

Yeah, I totally overlooked that statement. But either way, his original post states 2 RS+ receivers.

Needs to at least send the SIMPLE REPORT to help rule out the obvious.

1 Like

Here is a link to the simple report.

Send SIMPLE REPORT for ROVER also. Keep in mind as @bide mentioned, you won’t get a FIX using ONLY the BASE.

In case BASE file expires:

Simple system report
app version: 2.18.1-r0
'wifi_status, interface: wlan0':
- wifi_mode: ap
- access_point:
    band: bg
    channel: 1
    password: null
  ip: 192.168.42.1
  is_added: true
  is_connected: true
  mac_address: B0:F1:EC:02:17:3E
  security: wpa-psk
  ssid: reach_base:1C:73
  uuid: 24ae0bde-ce4c-4a9f-a6c5-62e15657d0f6
base mode:
  base coordinates:
    accumulation: '11.4'
    antenna offset:
      east: '0'
      north: '0'
      up: '0'
    coordinates:
    - '0'
    - '0'
    - '0'
    format: llh
    mode: fix-and-hold
  output:
    enabled: true
    format: rtcm3
    path: lora
    type: lora
  rtcm3 messages:
    '1002':
      enabled: true
      frequency: '1'
    '1006':
      enabled: true
      frequency: '0.1'
    '1010':
      enabled: true
      frequency: '1'
    '1097':
      enabled: true
      frequency: '1'
    '1107':
      enabled: false
      frequency: '1'
    '1117':
      enabled: false
      frequency: '1'
    '1127':
      enabled: false
      frequency: '1'
    gps:
      enabled: false
      frequency: '1'
    qzss:
      enabled: false
      frequency: '1'
bluetooth:
  discoverable: false
  enabled: false
  pin: '***'
correction input:
  input2:
    enabled: true
    format: rtcm3
    path: ttyMFD2:38400:8:n:1:off
    send position to base: 'off'
    type: serial
  input3:
    enabled: false
    format: rtcm3
    path: :9028
    type: tcpsvr
logging:
  base:
    format: RTCM3
    started: true
    version: null
  correction:
    format: RTCM3
    started: true
    version: null
  interval: 24
  overwrite: true
  raw:
    format: UBX
    started: true
    version: null
  solution:
    format: LLH
    started: true
    version: null
lora:
  air rate: '9.11'
  frequency: 868000
  output power: '20'
position output:
  output1:
    enabled: true
    format: nmea
    path: bluetooth
    type: bluetooth
  output2:
    enabled: true
    format: llh
    path: :9001
    type: tcpsvr
  output3:
    enabled: true
    format: llh
    path: :2014
    type: tcpsvr
  output4:
    enabled: true
    format: llh_ext
    path: :2015
    type: tcpsvr
rtk settings:
  elevation mask angle: '15'
  glonass ar mode: 'off'
  gps ar mode: fix-and-hold
  max horizontal acceleration: '1'
  max vertical acceleration: '1'
  positioning mode: kinematic
  positioning systems:
    compass: false
    galileo: true
    glonass: true
    gps: true
    qzs: true
    qzss: false
    sbas: false
  snr mask: '35'
  update rate: '1'

Question. So in setting up my base, there are options for single, float, fix. After starting the unit it notes, waiting to fix. What your saying is that unless I also have a Rover set up and operating I will not get a fix on the base?
If I manually input coordinates of a known control point, my rover should pick up corrected information from the base correct? The issue I have when I do that is that my baseline shows something like 7000 meters greater distance than it actually is. Any thoughts?

OK. I think you are making some incorrect assumptions that need to be cleared up first.

One Reach RS+ that is operating by itself is a standalone GNSS reciever. It can achieve a position accuracy of about 2.5m when its position is averaged for under 5 minutes. The position it gets will be computed from its raw data log in what is called ‘single’ mode. That means it is acting alone, just like any consumer GPS (Garmin, etc.)

Next, if you have two Reach RS+, you can log the raw data on each unit simultaneously. Afterward, you can take the raw data log file from each unit and process them together to get a position accuracy of about 2cm. This techinique is commonly called PPK. Each RS+ is operating in ‘single’ mode, and the coordinates you see displayed in ReachView are not important. What is important is the raw data that is being logged and the results you get after processing. Afterward, when processing the raw data logs collected from both RS+, you must choose:
a) which RS+ you want to act as the base
b) which coordinates you want to assign to the base
The result of the processing will be a position log of the rover, and the coordinates in that position log will be about 2cm accurate in relation to the base coordinates. Think about the relation. If you accidentally used base coordinates that were 10m north of the actual base location, then your rover coordinates will still be 2cm accurate to the base coordinates, but shifted 10m north of the actual position. The accuracy that is achieved is the distance between the base and the rover. If you want global accuracy, then you must take it upon yourself to determine globally accurate coordinates and assign them to the base.

The last thing is RTK. In PPK, the PP stands for post-processing; the final position is computed later. In RTK, the RT stands for real-time; the final position is computed immediately. Before starting, you have to decide which RS+ will be the base, and decide which coordinates you will use for the base. If you don’t already have coordinates or have the base set up over a ‘known point’, then the easiest thing to do is take an ‘average of single position’ for about 5 minutes. When that averaging is finished, now you have a ‘known point’. It may only be globally accurate to 2.5m, but if you reuse those coordinates every time you place your base on that point, your rover will be accurate in relation to that point and it will be repeatable each time you survey out from that point. Once the base coordinates are set, the base can be used to send a stream of data that is commonly called ‘corrections’. The rover recieves this stream of correction data in the form of RTCM3 messages, usually by LoRa radio. It could also be sent over the Internet, or Wi-Fi, etc. The rover then uses those RCTM3 messages to live-process its final RTK position. On the base, ReachView still shows ‘single’ mode and the coordinates shown there are not important. But on the rover, you should see a status of ‘float’, then ‘fix’ and that is when you can expect that the coordinates can be getting to about 2cm accuracy.

p.s this is all in the documentation, including the part about placing the base: https://docs.emlid.com/reachrs/common/tutorials/placing-the-base/
there you can see other options for getting a more accurate base position.

6 Likes