RS 2 base rover latency issue

Any news when a fix will be out for this issue.
It hasn’t worked right since ver. 27x

Hi Jim,

Can you describe the issue a bit? What setup do you work with?

Severe latency (19 seconds±) and decreased range when going base rover over lora. Worked fine under 27x then got noticeably worse with the 28x versions. E38 has been dealing with it on my behalf for over 2 months with your techs. Your guys should know all about it. Problem exists in brand new units so it should be software related. Considering the amount of time you have had to fix this issue I am assuming its not fixable and should start a warranty return?

Age of correction use to be solid at 1 to seconds
Now starts there and climbs to 18 or 19 seconds then back down and back up. Lora range has decreased dramatically.
Its due to one of the recent updates

Any update?

Hi Jim,

Oh, I see it. I’ve also clarified the details of your case with colleagues and now can bring them here.

By now, we’ve done some tests with E38 Survey Solutions, analyzed the data, and tried to reproduce the issue. Finally, we caught similar behavior in the office tests. Now we passed all the info to our devs, and they are keeping the investigation.

You’re right: the issue looks software-related. It means it should be possible to fix it remotely. Researching it will take us a while, but we’ll do our best to find a solution.

Our previous communication was via E38 Survey Solutions, but we can keep in touch directly with you to make it faster. So once I get any news – I’ll post an update in this thread.

As a current workaround, you can use NTRIP to work in RTK with the receivers. To pass the corrections between your base and the rover, you can use our free Emlid Caster. Or you can get corrections from the local NTRIP Service if you have one.


Thank you for your response. The reason I am using lora is lack of cell coverage so your workarounds are not possible. This has to be a major software glitch affecting everyone using lora.

A post was split to a new topic: Rising of age of differential via LoRa on RS2

Hi Jim,

I got you. But as we see it now, such behavior doesn’t show up on all the units. We keep a close eye on this case and continue investigating its roots.

I’ll write in this thread as soon as any updates are out.

Considering your response above i’m not getting the feeling that this issue will be resolved in a timely manor. It has been four months now since 28x has been out (which is what is causing the issue). Without lora these units have no value to me and I consider it a manufacturing defect. Since you claim it only happens on SOME units I want to exchange mine for ones that work while still under warranty. Please advise on how to start that process.

Hi Jim,

Andrew here. I’m in contact with E38 about your case, so I’m following the progress of the investigation.

Rising age of corrections
Usually, delays in the age of corrections can happen because of the following reasons:

  • Obstacles. The LoRa needs a line of sight for stable signal reception. In this case, this is a normal behavior of the radio
  • Interference. Various radio-electronic devices on the same frequency can significantly affect the LoRa range and signal reception. We do not recommend using popular frequencies, such as 868 ±0.5 MHz. You can test other frequencies starting from the highest available value and going back with the 2-3 MHz steps in the Correction output settings

In your case, we can see such delays on short baselines too. We’ve caught a similar behavior in our office. We’re checking the firmware to find possible reasons for such behavior and testing solutions.

At the moment, our tests showed that possible delays of correction messages that can be created from the software side are infrequent and not consistent.

The unit calculates the Fix solution when the position has a centimeter-level precision, resolving all ambiguities. Reach RS2 can calculate Fix with correction messages not older than a minute. Therefore, if you see a fixed solution with delayed corrections, you can be sure that the unit provides a centimeter-level accurate positioning.

Decreased range
You’ve also mentioned that the range on your units decreased significantly.

Unfortunately, I hear about this issue on your units for the first time.

The LoRa radio as a UHF radio highly depends on the environmental conditions and applied settings.

Any obstacles or hills significantly decrease the range. Other radio-electronic devices can create interference and reduce the range too.

Regarding the settings, please check the following:

  • Air data rate (ADR). The lower the ADR - the longer is the range. Please note that fewer RTCM3 messages can be transmitted with low ADR, so the time to achieve Fix and precision will be affected
  • Power. We recommend using 20 dBm by default. The lower is the power, the lower is a range

I reverted back to ver 27x the other day and it runs flawlessly. I did not change any settings. Its got to do with one of the 28x versions. LORA range is back up to where it should be. Suggest you examine what was changed on 28x.
As to “infrequent and inconsistent” its always bad with 28x and I know of another set of units experiencing the same issue.


We’re checking the firmware but haven’t found anything suspicious so far.

Can you share the exact settings you used in recent surveys and logs from them?

Reflashing to the previous firmware version resets all settings to default. Is it possible that you used a different Frequency?

If you don’t have files to share, please record the following data in your next survey and share it with me to

  • Raw data logs in UBX format on both units
  • RTCM3 and Solution logs on the Rover
  • Exported CSV from the project
  • Full System reports from both units

This data will significantly help us in our investigation.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.