ReachView v2.11.0 - Our second stable release

Hello everybody,

As you might know, we’ve been quite busy working on the new Reach M+ and Reach RS+, which are to replace the old models. If you want to take a closer look, our new store is gorgeous :sunglasses:

Although the new receivers are designed to not introduce any drastic changes from user’s point of view, we had to build our own platform from the ground up with the Neutis N5 modules. That’s a whole lot of work. However, I feel that for the future of Reach receivers it is an exceptional change. We’ve not only become more independent from suppliers, but gained much deeper control of the lower level of the platform. Some things on the Edison we had no control of were holding us back, but this is a new opportunity.

It’s been a rather long time since we split our update channels into dev and stable. I wanna say thanks to everybody who opted in for the dev updates, helping us verify things we could not otherwise. It’s time to pour the things back together, so we can split them into two once again :sunglasses:

I’ll only give a short list of all the stuff we’ve added and fixed over this dev update series, for the full list and explanations take a look at the dev release changelogs(v2.10.0/v2.10.1, v2.10.2, v2.10.3), these are very verbose.


  • Additional correction and GNSS predictor are deprecated
  • Second position output is back
  • New project export formats: CSV and DroneDeploy CSV
  • Surveying: point collection start and end times are saved into the project
  • LED: blink green to indicate app loading during startup
  • Shutdown and reboot buttons in ReachView
  • Pretty new logos :slight_smile:


  • Fix Wi-Fi not always connecting to known networks on startup
  • Tons of NMEA fixes! This release also includes a new NMEA fix - corrected position RMS values(RCH-1619)
  • RCH-1720 - Twitchy on/off switch in base mode


Thanks to user reports, we managed to fix a bug with manual base position. It would sometimes ignore the entered coordinates and use averaged instead, which might have resulted in shifts of the solution. The rebuilt versions are uploaded, you can grab them from our post-processing tutorial, as always. Unfortunately, we had to skip the Win32 builds, at least for now.

The next wave of dev updates with new features is right around the corner! Stay tuned :slight_smile:

Best regards,
Emlid team


Uhm, just a minor thing i noticed now. Was running dev 2.10.3 (Today), but it doesnt provide an update option or notify for latest stable release (currently 2.11.0) unless i unsubscribe the dev updates.
If somebody els was wondering

currently missing event was solved or not ?


I just test the new version of RTKLIB (b28 x64) and I still get difference with the previous version (b27 x86), up to 10cm in xyz.
you will find the processed file and log in the link below:


Emilien Aldana

I think it was mentioned somewhere that reflash is necessary to move from DEV back to STABLE.

1 Like

Yeah, i kind a thought so too. But since its was forward update it would be different :thinking::blush:
Would that mean DEV people would miss one stable version now and then? like going from 2.10.3 and straight to 2.11.1 ?

Well, I think the idea is in the last dev version of the series the bugs should be fixed, so it is pushed to the new new stable version. Like so: last dev => new stable

So someone correct me if I am wrong here. Yes the version numbers are different, but the code should be the same.

1 Like

I’ll fix this one soon, don’t worry. No need to reflash!


No worries. When hitting unsubscribing button, the option to update to 2.11.0 appeared :+1:

OK! Good to know!

i can’t see the update option in google play, where is that unsuscribe button you mentioned?

Its the Reachview inside your Reach, not the app.
Under settings in the Reachview menu, hit the unsubscribe button.

1 Like

Why GNSS predictor has been deprecated ? It’s a very usefull feature.
I have updated the app to 2.11.0 before noticing this. Is it possible to reinstall the previous version ?



We decided adding this to the app was a little bit overkill. Services like this are available online, if you are interested. For example, this.

Thanks for the link. It will do the job.
Another (small) issue : the XYZ logs are recorded in lat long.

Ok may be it was because it didn’t read correctly the last saved config of the previous version. After moving the scrolling list to lat long and back to XYZ, it records XYZ again.

1 Like

A post was split to a new topic: Can’t connect to Wi-Fi Network after update to 2.11.0

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.