ReachView v2.10.0 - Dev updates

Hello everyone,

It’s been some time since our last update, so today we have two new releases. They are slightly different in both features and their purpose.

Starting today, we are going to have two different ways to receive updates: a stable channel and a development channel. If you subscribe to the dev builds, you will start getting new features and fixes faster. The caveat is that they might not be completely stable before being released. Once we get some feedback from you guys, the feature will be considered stable and released for everybody.

Why do this? I’ve been working on Reach from the very beginning and have seen it evolve from a crowdfunding campaign to a full blown consumer product. Then Reach RS came and I started seeing Reach more and more in professional applications. Integrated in other products or used by professional surveyors, this is a different level of responsibility for the software team. The team, on the other side, still needs to move fast. So, it was decided to split the updates in two channels.


  • Ability to switch between stable and dev updates. “Check for updates” button included!
    Warning: once you update to a dev build, you will not be able to revert back to stable until the next stable release. In case you absolutely have to revert, you will need to reflash.

        Switching to the dev channel paints your updates in a nice green hue :broccoli:

  • “System reports” to facilitate describing your problems to the community and to us. There are two kinds: one in plain text, and one as a zip archive. The former is for the forum, and makes it really easy to share the usual stuff like your settings, network state and app version. The latter is for harder cases and contains system logs and technical details of your device.

    You can now simply copy your device’s settings with one click and paste it to the forum, instead of posting screenshots.

Click this guy :point_down: for a preview

Simple system report
app version: 2.10.1-dev-r0
'wifi_status, interface: wlan0':
- Client state
- IP address:
  mac address: 90:b6:86:0a:dd:52
  ssid: EML33T2
base mode:
  base coordinates:
    accumulation: '2'
    antenna offset:
      east: '0'
      north: '0'
      up: '0'
    - '0'
    - '0'
    - '0'
    format: llh
    mode: single-and-hold
    enabled: true
    format: rtcm3
    path: serial://ttyMFD2:57600:8:n:1:off#rtcm3
    type: serial
  rtcm3 messages:
      enabled: true
      frequency: '1'
      enabled: true
      frequency: '0.1'
      enabled: false
      frequency: '1'
      enabled: true
      frequency: '1'
      enabled: false
      frequency: '1'
      enabled: false
      frequency: '1'
      enabled: false
      frequency: '1'
      enabled: false
      frequency: '1'
      enabled: false
      frequency: '1'
      enabled: false
      frequency: '1'
  discoverable: false
  enabled: false
  pin: '***'
correction input:
    enabled: true
    format: rtcm3
    path: ttyMFD2:38400:8:n:1:off
    send position to base: 'off'
    type: serial
    enabled: false
    format: rtcm3
    path: :9028
    type: tcpsvr
    format: RTCM3
    started: true
    version: null
    format: RTCM3
    started: true
    version: null
  interval: 24
  overwrite: true
    format: UBX
    started: true
    version: null
    format: LLH
    started: true
    version: null
  air rate: '18.23'
  frequency: 868200
  output power: '14'
position output:
    enabled: true
    format: llh
    path: ttyMFD2:57600:8:n:1:off
    type: serial
    enabled: true
    format: llh
    path: :9003
    type: tcpsvr
    enabled: true
    format: llh
    path: :2014
    type: tcpsvr
    enabled: true
    format: llh
    path: :2015
    type: tcpsvr
rtk settings:
  elevation mask angle: '15'
  glonass ar mode: 'off'
  gps ar mode: fix-and-hold
  max horizontal acceleration: '1'
  max vertical acceleration: '1'
  positioning mode: kinematic
  positioning systems:
    compass: false
    galileo: false
    glonass: true
    gps: true
    qzs: true
    qzss: true
    sbas: true
  snr mask: '35'
  update rate: '5'

Warning: the Android/iOS apps support the full system report feature starting with version 1.2. These versions are currently being rolled out to both stores.

  • Peru users will now have their LoRa frequency bands automatically limited to a 915100 - 927900 kHz range


  • RCH-886 - After losing network connection in client mode, Reach will no longer be “stuck” connected to nothing, but will be actively reconnecting to the missing network
  • RCH-889 - Support for GLONASS MSM 1084, which does not contain the satellites’ frequencies
  • RCH-874 - No longer write L2 flags to the Reach-generated RINEX file header
  • RCH-809 - Changing device name does not produce a reaction in the app
  • RCH-859 - Fix DNS not working with certain types of USB modems
  • RCH-894 - Another fix for working with QZSS corrections
  • RCH-714 - The “@” symbol breaks NTRIP configuration screen, if used in username or password. The “:” and “/” symbols are still forbidden!

Dev update features

This dev release already has some new cool stuff to lure you guys in :slight_smile:

  • Position output tab rewritten from the ground up
  • Second position output is back
  • The new forms have a fancy new validation system. Warnings with detailed messages will make Reach configuration less error-prone
  • Additional correction and GNSS predictor are deprecated
  • RCH-863 - ‘GNSS select’ will no longer allow users to set up GLONASS/BEIDOU with update rate > 5 Hz
  • RCH-787 Turning on BEIDOU if GLONASS was previously on does not work

We see all this preparation work as a foundation for faster growth. At the same time, this will protect users that rely on Reach in their day-to-day work.

Best regards,
Emlid team


Can’t wait to test this out in the New Year.

Awesome. An easy choice for me. Already updated to dev. release v2.10.1.

Is this not an auto update?
My module is indicating uptodate with 2.9.3
Ok I got it by going to the reach.local:5000

my rs died turing update process. (from latest 2.9…)

…reflashing now

cool runs …

Hi Egor,

  1. My Reach is currently running ReachView version: v2.9.3-r0 but it says “You are up to date!” so it is not seeing firmware 2.10.x what shall I do to update?

  2. Solution found, it was easy, just type http://reach.local:5000/

  3. Now I downloaded and Installed firmware 2.10.0 but if I press the “Check for updates” button inside the settings it keeps “Checking for updates…” forever so I’m guessing that my router is blocking some ports that the Reach requires to retrieve the new firmware information. Any help would be appreciated.

  4. Damn! I had to reboot the Reach after the firmware update :see_no_evil: now I’m in dev. build. 2.10.1 sweet, problem solved!




Is there a reason why

“Additional correction and GNSS predictor are deprecated” in the dev version ?

Reach usually checks for updates once, at boot time. The new version has a button to check it manually.


What happened? Did it freeze? Could that have been due to a poor Internet connection?

yes i think there was a short break of the internet connection…

it did freeze then during the update process… at downloadind xy…

i did wait min 10 min.
after a reset i did not work…

i did use the intel edison tool because install.bat did not work…

Reboot is compulsory after an update. Thanks for opting in to the dev builds :slight_smile:

Thanks, I’ll check if something can be done about this.

this is the output of flashall.bat:

Using U-boot target: edison-blankrndis
Now waiting for dfu device 8087:0a99
Please plug and reboot the board
Der Befehl “dfu-util” ist entweder falsch geschrieben oder
konnte nicht gefunden werden.

Sure, there are.

Additional corrections is specific to either non-RTK modes in RTKLIB we do not support or precise ephemeris, which hasn’t been tested properly. We haven’t seen anybody actually use them as well.

The predictor used to be a good idea back in the day. Since then, we have drastically improved Reach’s RTK performance, so it is not necessary. You can still use an online service for this, though.

Both of these features are mediocre, but they still drain the team’s time and effort. We decided to focus on things that matter instead.

Seems like the flashing utility is not installed. It is usually installed as a part of the Flash tool lite, so I would suggest to reinstall it if you ever encounter this again.

Wow! Great work guys. I can’t wait to test out these new features. :grinning:

1 Like

should be another problem…

did install usb drivers again
and intel Flash tool lite.

same message

(with Intel Edison Board Configuration Tool it works)

since I updated to 2.10.0, the android RV app doesn’t seem to find my ReachRSs anymore, neither in hotspot nor in client mode

Hi Egor

For some reason that unit did not come up with the update rebooted several times but manual :5000 worked.
I have done 3 more units and they all came up with the update as expected. All is working now


1 Like