ReachView, Re-Flash, Access Issue

I have two Reach RS units. I am able to connect via WiFi to both on port 5000. All the tests pass, and the time syncs. However, Reachview under IOS doesn’t see them, and a web browser (port 80) won’t connect. I can ssh to them, but see nothing listening on port 80. Some docs say that it needs to time sync before this process starts, but when I access via port 5000 it shows everything as being okay. So, after screwing with this for a few hours, I attempted to re-flash, under OS X High Sierra and Mohave. The only message I get is the incredibly unhelpful: “Did you plug and reboot your board?”. And yes, I unplugged several times, rebooted more times that I can count, with no success. So I tried a PC, but when running the reflash batch file it simply closes the window and does nothing. Since I can directly connect to the device via SSH, I’m hopeful there is a way of updating the firmware directly instead of using the reflash utilities. As an aside, this seems to be a very common issue with these things. I’m hopeful there is some resolution before I take both to the gun range and and create a high-speed YouTube video showing the effects of a .50BMG round on two Reach RS Units. Any help will be greatly appreciated.

The flashing issue turned out to be a bad (or at least bad for this operation), USB cable. I had previously tried two other cables. This time I pulled one from a DJI drone, and the flashing worked! My apologies for the noise.