Reach will not add new wifi network


I have 2 reach units. One works and the other is giving me the worst time ever!

i can find the reach AP and connect to it. Going to to add new wifi network. I click add and enter the details of the wifi network, then click done. Usually you get the name of the network, which you click and connect to. However, i dont get anything…just the same start page when i enter
I re-enter the wifi network again, and again nothing…

I tried reflashing with intel’s tool…FAILED
i tried reflashing with the ./ command …FAILED

the flash.log last few lines:

Filter on vendor = 0x8087 product = 0x0a99
Opening DFU USB device... ID 8087:0a99
Did not find cached descriptor
Warning: Assuming DFU version 1.0
Run-time device DFU version 0100
Found DFU: [8087:0a99] devnum=0, cfg=1, intf=0, alt=7, name="rootfs"
Claiming USB DFU Interface...
Setting Alternate Setting #7 ...
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
Did not find cached descriptor
DFU mode device DFU version 0110
Device returned transfer size 4096
Copying data from PC to DFU device
Starting download: [#############################dfu_download: libusb_control_transfer returned -7
Error during download
can't detach
Resetting USB to switch back to runtime mode

Also, i cant ssh into the unit! After i enter the password after ssh, i get nothing…
the reach unit keeps blinking red, green.
I am running ubuntu 14.04. Using reach image 2.3

Any ideas? Anyone faced this before?

[EDIT 1]: showing output of Intel platform flash tool lite

03/22/17 15:49:37.707  WARNING: [Port 1] Command `"/opt/intel/platformflashtoollite/bin/dfu-util" "--alt" "u-boot-env1" "-D" "/home/ahmad/rtk_reach/ReachImage_v2.3/u-boot-envs/edison-blankcdc.bin" "-t" "4096" "-R" "-d" "8087:0a99" "--path" "3-1"` failed
03/22/17 15:49:37.707  INFO   : [Port 1] Retrying `"/opt/intel/platformflashtoollite/bin/dfu-util" "--alt" "u-boot-env1" "-D" "/home/ahmad/rtk_reach/ReachImage_v2.3/u-boot-envs/edison-blankcdc.bin" "-t" "4096" "-R" "-d" "8087:0a99" "--path" "3-1"` command
03/22/17 15:49:37.835  ERROR  : [Port 1] Command `"/opt/intel/platformflashtoollite/bin/dfu-util" "--alt" "u-boot-env1" "-D" "/home/ahmad//rtk_reach/ReachImage_v2.3/u-boot-envs/edison-blankcdc.bin" "-t" "4096" "-R" "-d" "8087:0a99" "--path" "3-1"` failed
03/22/17 15:49:37.835  ERROR  : [Port 1] Flash failed (Command type: DFU)
03/22/17 15:49:49.749  INFO   : [Port 1] Device lost on 1
03/22/17 15:49:51.761  INFO   : [Port 1] New device detected on 1 (id=0100000000000000)
03/22/17 15:49:55.795  INFO   : [Port 1] Device lost on 1

[EDIT 2]
the reach unit now only flashes red and green. no AP no noting…

@igor.vereninov @bide any ideas? appreciate any kind of help guys.

Sorry, I’ve not faced this before.

Well, your Reach seems to work in the sense that you can browse to and interact with the web page. Being that ssh is partially broken and you can’t continue with wifi setup to get to ReachView, I would reflash. Let us assume that your Reach unit is OK, but the reason you can’t reflash successfully in Windows or Linux is because of something else:

  • post the filename and md5sum of the firmware you are trying to flash, and then try again with a fresh copy or an older firmware version
  • try different USB cable(s)
  • try different USB port (back of computer instead of front - the one right beside the one you already tried probably won’t make a difference)
  • try different computer(s)

Could you please make screenshots of what you are doing and what is going wrong?

i tried everything using Linux and then windows, but still wont work.
I just tried it using a mac, and re-flashing immediately worked, from the first time…

I re-flashed and everything is okay now…what was the main problem? noooo idea…
keeping in mind that i did try different cables, different ports, several restarts etc… on linux and windows

it worked now, thanks

1 Like