Reach wifi getting on same network?

I am having trouble getting both modules on wifi. One shows up as “reachjim:1b:bc” . The other one shows up as “reach:65:00”. So cannot get them to connect together. How can I change to make them the same wifi network?

Also how do I know what is the current version of reachview app and also firmware?
Thanks
JIm

For the ReachView version, go to: https://github.com/emlid/ReachView

  • click on “Branch: master”
  • click on “Tags”
  • there you can see the latest ReachView version number

For the latest Reach/Edison firmware version, go to: https://docs.emlid.com/reach/firmware-reflashing/#emlid-reach-rtk-firmware-download

Typically, one would connect Reach to a wireless access point (a router or cell phone hotspot). Then they can communicate through the access point, and get updates from the internet if it is available. I would recommend setting it up that way.

However, if you really want to connect them together, you could probably enter the hotspot essid and password of your Reach base unit into your Reach rover unit. The disadvantage in doing that is that whenever your rover is powered up near the base, it will connect to the base’s hotspot, and it will be impossible to access the rover’s ReachView app without a ethernet over USB connection or some fancy port-forwarding or iptables rules. So the bottom line is: it’s probably not a good idea to connect them together that way. see next post

Hi! Thanks for the input!

That is not correct. Whatever the master Reach is, it acts like a fully functional router. So, it will assign an IP address to the new connected device. Connected Reach is usually available on 192.168.42.20 or by its .local handle.

It’s perfectly acceptable to connect one of the units to another’s network.

Yeah, this is the working repository. You can just click “Releases”.
We usually announce important changes here, at the forums.

1 Like

Thanks guys

I got them showing up on one wifi spot but they both end in “.1”. When in reachview how do I change from one to the other? Does not seem real clear to me on how to do that. Had one in rover that appeared to be working but dont think it was connected to base.

Thanks Jim

What do you mean by showing in .1?

It seems you are actually looking at the same one. You can connect your phone to Reach-created wireless network and use FING to scan it.

I am looking on fing and it shows the 2 modules plus the ipad. The 2 modules have the same address showing in fing they both end in .1 The document tells you to use fing and if more than one “read more on resolving IP addresses in the reachview section” but I dont see anything there?
thanks
Jim

Please post a fing screenshot.

this is the screen shot
Thanks Jim

This is really weird. After multiple tries I can not recreate this behaviour. Have you tried a different approach? For example, connecting both Reach units to your iPad hotspot?

Question on the network topology you are using to connect to.

Have you considered connecting one reach at a time to the network and connecting?

I have no idea what the symbol means.
I think I will try redoing it all? I have at various points had the base getting sat info and the rover but not at the same time
Thanks Again
JIm

on the symbols in the screenshot above:

from: http://www.dexterindustries.com/howto/fing-tool/

1 Like

Hello All

Tried redoing this setup. Not making any progress. Any one have a video of setting up the reach modules. What is the process for each in the edison setup? I must be doing something wrong? Need help

Thanks
Jim

Did you follow the docs procedure?

Good Morning
I thought I did but? Unfortunately when I redid it yesterday I got the same result as the screen shot posted earlier. I believe it is something in the joining of networks as they came back with the same IP address again?
Thanks
Jim

Let me propose this situation:

  • a Reach unit called Base running with it’s hotspot on
  • a Reach unit called Rover running with it’s hotspot on
  • a cell phone nearby which is familiar with both the Base and Rover wireless networks
  • cell phone is looking for an internet gateway and so it will try connecting to familiar networks or open networks
  • cell phone is currently connected to Base
  • Fing scans network and finds Base on 192.168.42.1 and Fing remembers this
  • a short time later cell phone automatically connects to Rover
  • Fing scans network and finds Rover on 192.168.42.1 and Fing remembers this
  • cell phone user opens Fing app and Base and Rover are listed with the same IP: 192.168.42.1

Is is possible that @jmcarthur is experiencing something like this in his Fing screenshot?

This would explain why he only receives satellite info separately and not at the same time. Either base or rover is connected at a given time, never both?!

Good morning all

I finally figured out the problem. I knew it had to be me.
When on the Edison setup page:
1 > I would enter the network name
2 > It would say “open” on the next line down (figured it would open the name)
3 > I would click submit

I should have been doing
1 > enter the network name
2 > selecting the security feature "wap2 personal"
3 > Enter the password when this line comes up now
4 > click submit ( suggestion to add a clarification to documents)

Now I am able to access both modules. Although I never did get a float or fix but did have 6 to 10 green bars and 4 to 6 grey bars.

I still have not been able to join to my internet network to do updates though the above did not seem to get me there.

Any help on the new things appreciated

Thanks for the help
Jim

Good to know you resolved the issue!

In regards to the update, what is the network the units are connected to?

I tried to connect to my router at netgear but does not seem to connect to it?
Thanks
Jim