Reach updating and bluetooth

Hi all! I’m brand new to Reach, and I’m trying to get Bluetooth to work. The unit has been flashed with the latest image (1.2), but when I go into the settings in ReachView it says Current version: v0.0.3. I’ve tried to update, but it’s stuck on 0.0.3.

I’ve ssh’d into the unit and enabled Bluetooth there, and managed to pair it with my phone successfully. There is still nothing mentioned about bluetooth anywhere in the settings or configs. Has anyone experienced anything similar?

No bluetooth in 0.0.3. ¨
What do you mean by stuck on 0.0.3? Error displayed?
Do you have screenshot?

I mean that I see the “update” button in settings, when I click it the unit goes through a reboot as expected but still lists 0.0.3 as the current version. As if it tries to update, but can’t for some reason. Does the update process create a log somewhere in the system I can look at?

there’s a cache issue with the older versions. try control-shift-R to refresh ignoring cache.

1 Like

That is latest stable firmware image, and from there you can get to ReachView 1.4.9, but there is a newer beta firmware image that will let you get to ReachView beta version 2.x

1 Like

Not familiar with 0.0.3.
But would try clearing cache or run browser in incongnito mode(recommend Chrome for this).

I have tried multiple browsers across multiple computers/devices with no luck, so it is not cache-related. It’s still showing up as 0.0.3 (released in December 2015).

Is there a manual update process; is it as simple as doing the same operations as in /home/reach/ReachView/, or are there additional operations as well?

Nevermind; I ended up flashing it to the latest Beta instead of trying the manual route. Everything seems to work a lot better now :slight_smile: