Reach unit won't join WIFI network

Both of my Reach units have been working fine up until now, with credentials set up for both my home WIFI network and my mobile phone hotspot, for when I am in the field. As of last week, one of my Reach units will no longer connect to either network - instead, it just creates it’s own hotspot like it does before any WIFI credentials have been entered. I have tried re-entering credentials for both my home and mobile network, with no change in result. When updating WIFI settings, the unit does shut down it’s own hotspot but does not connect to a network - so it sits there and cannot be connected. If I then power-cycle the unit it once again creates its own hotspot - it does not join a network.
Any idea what is going on? I’d rather not reflash anything, but if there is a wifi config file I can remove via ssh then I can give that a try - can you point me in the right direction?

Any thoughts on this Igor?

Just an idea. I wonder if your Reach is somehow blacklisted by your router. Do you have another wireless network that you could try to connect it to? Maybe a hotspot on your phone?

I’ve had trouble before where it was the router refusing the wireless device.

Thanks for the idea, but the Reach was happily connecting to both my home network and my mobile hotspot. Now it won’t connect to either, and it’s really starting to annoy me! I can still use it by connecting directly to its own hotspot, but that means I can’t remain connected to both of my units at once.
Does anyone know where the wifi configuration file is? Is it safe to delete it?

Hopefully someone knows the whereabouts of the wireless configuration.

I would say that if Reach stores your Wifi essid, then you can search for it as a keyword. Maybe ssh into the working unit and do this:

cd /etc
grep -r my_essid * # where my_essid is your home network id

If that doesn’t turn up anything, then:
cd /
grep -r my_essid *

…and let me know if you find it.

1 Like

Thanks bide, located the file wpa_supplicant.conf (in directory /wpa_supplicant). Deleted (or at least, renamed) and then re-entered credentials. All is well :slight_smile:
One thing that might be of interest is that the file contained 4 x entries for my home network - all identical - and one for my mobile. My guess is that this is the number of times I tried reconnecting. Something a bit glitchy is going on here, but at least the fix seems fairly easy.