Reach RTK Problem accessing ReachView

I am having an issue trying to access Reachview to set up a Reach RTK. So far, here are the steps I’ve followed:

  1. Successfully installed drivers via the Intel Edison setup tool (using the manual workaround placing the required files in the same directory)

  2. Proceeded with the actual firmware flashing process using the command line approach (since the flashing step did not complete using the setup tool)

2-a. Prepared the directory by placing files into it as follows:

  1. Navigated to the directory and ran flashall.bat

  2. I was prompted with a message waiting for the edison unit, so I plugged in the reach

  3. The flashing process ran (apparently successfully) and I was prompted to wait for Reach to reboot to complete the flashing process before unplugging the unit.

  4. After the LED turned off for a few seconds, I saw a single blue blink followed by solid magenta on the LED (which would suggest either hotspot mode or connected to wifi). This did not change regardless of how long I waited (I assume it should be cycling through several stages in the reboot?)

  5. Unplugged the reach, reconnected to the power source with the same result (single blue blink, solid magenta).

  6. Despite the solid magenta, reach was not creating a hotspot and was not connected to any wifi network. (note: as this was used before, if it is close enough it does connect to my university’s wifi network which I can verify with Fing, but I cannot access reachview in my browser using its IP address).

  7. Repeated the flashing process multiple times to see if it would help, but I have the same result.

Try accessing the updater page on port 5000 and see what happens.
Also try to ssh in and see if that is working.

Hi and thanks for the advice, I appreciate it. Unfortunately the port 5000 option (I assume you mean appending :5000 to the IP address?) didn’t work when I tried it at the university, and at home I can’t even attempt it since the Reach isn’t connected to my wifi network and isn’t broadcasting its own hotspot. Briefly looking at the ssh option I would also need that to be connected to the same network so that seems to be out as well.

OK, then try setting up ethernet over USB.

Plug Reach into your computer or laptop, and see if you can access ReachView through the USB cable.

What operating system do you run? Linux?

When the reach is plugged into the laptop by USB, I am able to see it as a disk drive (wasn’t able to before firmware flashing), and as far as the connection goes, it shows up as “Unidentified Network, No Internet”. I work on a Windows 10 laptop

OK, well you need to set up NDIS if you have Windows 10. Search the net for those instructions. Set the address of your NDIS interface to 192.168.2.0/24 or similar because Reach assigns itself 192.168.2.15 and you want to make sure your NDIS is on the same subnet.

If you get that working then try your browser again with:
http://192.168.2.15
or
http://192.168.2.15:5000

If that works, then search on how to share internet with your NDIS network, so that Reach can update itself. If that works, then maybe the software update will fix up the problem. Otherwise you are back to reflashing. But this time do it while booting from a Linux live USB stick or at least try from from a different computer.

Good Luck!

1 Like

Hi, having done some playing around with this and watch tutorials on the NDIS setup, I haven’t found any instructions specific to Emlid But I’ve tried the following:

  1. Located reach’s network driver in device manager as follows:

  2. Proceeded to update the driver:
    image

  3. Specifically searched for the Microsoft -> USB RNDIS Adapter as follows (also tried with the RNDIS6):

  4. Hit next, then yes after the compatibility warning
    4a. The driver installs successfully, at which point I would have expected the USB network to connect but instead it shows “identifying” for a few seconds then becomes unidentified network again.

  5. Input 192.168.2.0 as the address (192.168.2.0/24 is apparently too long):
    image
    then closed the dialogue
    5a. This prompted the network to read “identifying” again for a few seconds before reverting back to unidentified network:

  6. Tried accessing reachview at http://192.168.2.15 and http://192.168.2.15:5000 in an incognito window:

  7. Repeated the process with the RNDIS6 driver

Somewhere I must be misunderstanding this or messing it up, but I don’t know where. Is there a different driver I should be using to update, or should I be updating a different driver altogether? Also did I misunderstand what you meant about the NDIS interface address? I can’t append /24 in that window so I figure maybe it’s some other interface I should be changing. Sorry, I’m totally new to messing with NDIS drivers so I’m a bit lost.

OK, well 192.168.2.0/24 defines a network of addresses from 192.168.2.0 to 192.168.2.255 with a netmask of 255.255.255.0

Since you just need to specify one address in your settings, pick: 192.168.2.1

I think it should work after that!

***nice set of screenshots and explanation by the way. That really helps paint a good picture of what you did :+1:

How long, approximately, did this take? It should have taken at least 5 minutes.

Hi again, in answer to efedorov, the flashing process took about 6 minutes and I waited about 5 minutes after that to be safe (the prompt says to wait 2 minutes).

Unfortunately the specific NDIS address suggested by bide didn’t help either (I tried a range from about 1 to 20 without success).

I don’t know if it helps with error diagnosis, but when I connect via USB, the drive for the reach has nothing on it:


Is it supposed to be empty like that?

Thank you both very much once again for all your help

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.