Reach RS2 will not connect and update

I have 2 X Reach RS2 which I have not used for several months. I am now preparing them for a project, but they will not connect and update. I searched on the Emlid forum and found similar problems. Following the proposed solutions didn’t result in a connection for me.
I have tried with 3 different phones and 2 different networks without success. I cleared data and cache and enabled all permissions and reinstalled Reachview App 7.10
The sequence to attempt connection is shown below.



Hi !
At this point you may try to reflash the firmware Firmware reflashing | Reach RS2/RS2+.

Have you tried that ?

1 Like

Flashing firmware was a last resort. I will try that if there isnt another solution i havent tried.

I flashed the base and rover with the latest firmware without issues. There was no problem maintaining a connection over the usb cable.
However after flashing, neither the base or rover will connect and I cannot complete the setup.
I reflashed the base and rover a second time, reinstalled reachview 3 and tried another network and phone but still no luck.
I have no other ideas. There is not much I can do if I cant connect with the receivers.

When emlid is flashed all settings are erased, including wifi keys. Try to see if it connects to the network.

1 the phone makes wifi connection to the receiver - solid white led
2 open reachview, receiver passes tests - green check mark
3 in reachview, connect receiver to my local wifi - receiver disconnects - flashes blue searching.
4 phone is connected to local wifi but receiver continues flashing blue and doesnt connect.

Hi @itenviro,

Indeed, looks like your receiver can’t connect to your Wi-Fi network. Is it on 2.4 GHz? That’s the frequency our receivers work on.

It is strange that both receivers exhibit the same behavior. But I have tried them on 3 other networks and with 3 diffetrent phones. I last used them about 5 -6 months ago.
I dont know what else to try.

wifi

Hi @itenviro,

What about using the phone’s hotspot? It’ll be quicker to update the units through the available network and then search for the solution with your home Wi-Fi.

Just double-check that your hotspot is also on 2.4 GHz: sometimes this functionality is set to 5 GHz by default.

1 Like

I will give that a try and let you know in a few days.

2 Likes

I succeeded in connecting both rs2 units to the phone hot spot but still not to the local wifi.
No idea what the problem is having gone through so many attempted solutions …

A post was split to a new topic: BT connection issue

Hi @itenviro,

I see. If the unit connects successfully to other networks, it seems like it works correctly. So it looks like your home network has some specific requirements. It’s quite difficult for us to analyze them.

The most usual issue is the number of connections that your router can handle. I suggest checking it additionally. If you have any other routes to double-check with, it may be a good idea to try them on to check if there are any differences. Additionally, the reboot of the router may help to make the network visible.

That’s what I have in mind regarding the issues from the router or network side. If you’re not successful after that, you can try connecting the device to your home network once again and generating the full system report from the device straight after. Please share it with us via support@emid.com to avoid sharing sensitive info publicly. This will help us to see what happens on the unit’s side. If there are any issues, we will be able to detect them.

Thank you. I did try to connect to two other networks but was unsuccessful with those too. In any case, i will generate a system report as you suggested and send it to you in the next few weeks.

1 Like

Make sure to let us know here if you get a solution. Thanks!

Also try to change your WIFI broadcast name and password to something very simple without special characters just to see if that has any effect.

Will be waiting for your report, then! And it’ll be nice to check Tim’s suggestion additional, just to see if there’s indeed any difference.

1 Like