Reach RS2 FLOAT solution

Recently acquired the RS2, after more than 8 years using the CRTN with no issues (Spectra precision PM500 & PM220 models). I’m trying to connect to the CRTN southern CORS stations with no success. I obtain a FIXED solution for a few seconds then return to FLOAT solution. Any clue? Any one solve this issue?

The caster provide me GPS and GLONASS corrections only.
I have the latest firmmware installed


1 Like

try stable version 2.22.2 or version 2.23.4dev


Could you provide me the zip file for that versions?

I installed an old version 2.20.5. But I was unable to pass to reboot, because when I re-enter to reach view after the reflashing procedures ends, the system requires me to update, as shown on the screenshoot below.
After this, I was forced to reinstall the latest version 2.22.3 (the same that gave me problems to obtain fixed solution) and by the end return to the same problem.

Below are the screen shoots that shows the settings I have been using. The provider (CRTN) only transmits GPS and GLONASS corrections.

after reflash connect to wifi but disable internet access (then you do not need to update to the latest version) ex. disconnect internet cable from router

Hi @JoseDuran,

We recently released the new dev v2.23.4 of the ReachView app. This version is mostly used for testing purposes. However, there should be significant improvements in RTK performance. So it’d be nice if you could try it and let us know if this version helps you out.

After spent 2 hours doing the upgrade to v2.23.4 and some tests outside, I obtained the same results.

Any other clue to solve this?

Hi Jose,

Do you have another mount point of CRTN within 60 km to try? As far as I know, RS2 should work fine with this service. Would be great to make sure it’s not mount point related issue

Also, please post a screenshot from RTK Settings tab where the messages from NSSS mount point are shown

I tested using several mount points, with the same result.


At this point we’ll need raw logs from your caster and rover unit from the session where you couldn’t obtain fix.

Another idea, does anything change if you use GPS only?


Here are the logs for a 10 minutes session, with no fix.

The image below shows a session using GPS only, same results. At the lane position it looks like the same precision when I used the GPS+GLONASS. It seems GLONASS is not participating helping me to obtain a fixed solution.

Thank you!

Below is the image of the RTK session for the session when I logged these files:

Here is the correction input settings: (2.6 MB) (205.5 KB) (87.1 KB)

Awesome, thank you for the details, we’ll look into this in the nearest time!


Why don’t you have “send NMEA GGA messages to correction providers” selected? In my opinion, this option is necessary for proper operation with the NTRIP server


I tried with two caster providers. 3 cors stations are unable to provide me fixed solution. Other are working good. I connected to internet using home internet and my cellphone as a hotspot.

Thank you!

Hi @JoseDuran,

Glad to hear you obtained a fixed solution!

However, I’d like to investigate what’s wrong with the other 3 CORS stations. Could you also share the logs from these tests?


Here are you requested me:
1740 is for the NSSS mount point (not getting fixed solution, 9 kms)
1744 is for the P473 mount point (not getting fixed solution 26 kms)
1749 is for the P066 mount point (not getting fixed solution but maybe because is located at 73kms)
1753 is for the P475 mount point (working good 23 kms)

Let me know if you need something else.

Thank you. (42.2 KB) (212 Bytes) (57.0 KB) (37.4 KB) (545.5 KB) (763.9 KB) (729.9 KB) (531.7 KB) (14.9 KB) (14.6 KB) (14.7 KB) (9.7 KB)

Here you can download an excel table with all the cors stations for the California Real Time Network (in yellow the ones I used):

Hi Jose,

Thanks for the logs. I’ve analyzed them, and there are no obvious reasons for such differences in the results. Please take a look at the screenshots. The rover raw data log is at the top, and the NTRIP log is at the bottom:

  • NSSS mount point

  • P475 mount point

In both cases, we have 8 common satellites with stable SNR values of about 45. However, a fixed solution was obtained with the P475 mount point only.

According to the CRTN station list, NSSS, P473, and P066 mount points are owned by SDCRTN sub-network. And the last one is owned by NOTA.

To investigate if there are any differences between these sub-networks, may I ask you to share with me screenshots of the Correction input tab with the RTCM3 messages list? To display this list, please press on the arrow in the lower right corner of the window.


Hello Svetlana,

Here are some screeshoots.

Thank you.