Reach Rs not chariging after being stored for 2 months

I have 2 reach rs receivers after 2 months of being stored neither unit will take a charge or power on. I have tried multiple 5v 1A charges with no success.

Hi @joemiller5825,

Do you have 2 Reach RS units, not RS+?

How long have you charged the units? Please try to put them on charge using other USB cables overnight, and then turn them on without disconnecting.

Is there any LEDs status when you’re trying to turn them on?

I have RS+. I have tried charing overnight. I have tried turning them on while plugged in and they will not turn on. when I try to turn the unit on while plugged in all 3 lights will light up as long as I am holding the button.

both of the (2) RS+ receivers do this same thing? maybe make a video to help illustrate the problem?

Hi @joemiller5825,

Did these units work previously?

Could you contact us on

In your email please provide:

  • the Serial Number of both Reach units;
  • Order Number (if bought from Emlid Store);
  • Shipping address.