Reach RS+ cant´t connect to PC by USB: no COM port

Hi guys
My Reach RS+ unit works great as base station while it has wifi connection shared with the PC, but I wanted to check how to share the data to the PC by USB.
According to what I read, just plugging the unit into the PC by USB creates the COM port, but it doesn´t happen to me. No COM port created in any of the PCs or laptop that I tried.
I´ve heard there is no drivers to install that it works just plugging in. Has someone got any idea?


Hi @g.naveiras,

As I mentioned in my email to you, it seems that you haven’t got serial drivers for Reach on your PC. Can you try to follow steps for Zadig driver installer from this tutorial?
Instead of WinUSB driver as in docs, choose USB Serial driver and install it after connecting Reach to your PC.

Please report if you’ll still have the problem after that.


I know the DOCS are always VERY well designed and written, but I noticed that even though it does specify and separate the prior RS model and the NEW RS “PLUS” model, it may be confusing to most when they first see this and try reflash or install serial drivers? Maybe a BIT MORE seperation between the (2) units and their procedures may help a little?

Again, such a wonderful job throughout the Emlid site etc, but at times to new users at first, there maybe some things that may be a little confusing. Just a little advice is all. ; )

Thanks Andrew for your help
I did it as you said and I managed to make it work in a desktop PC, but when I try to do it in my laptop PC it gives error message “Driver instalation failed: Other error”. After that the COM port appears at Device Manager, but with a warning sign.

Laptop OS runs at 32bits and desktop at 64, don´t know it it makes a difference.

Hi, that tutorial worked in my computes (with OS windows) but when I tried it in a raspberry pi with linux, it didn’t work.

Do you know why?

I tried in another laptop with 64 bits OS and it worked without problem

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.