Reach no longer doing much. Not working properly after reflashing

I haven’t used my two Reach units much this year.
Earlier I did try to upgrade the firmware and it failed on both units. It was a beta version. I went back to v1.2 on both units and they worked again fine.
Now I tried to upgrade again. The one unit worked perfectly with 1 try. The other however has gone from bad to worse. I had trouble reflashing it with an Ubuntu machine. I could flash it and give it my network name but it would never join my home network. It would show up as usb0 and once I started a SSH session but didn’t get anywhere. The one quirk that was consistent was that I never had to enter the password when connecting to it’s hotspot. It was able to get reflashed, boot and establish it’s own hot spot but never join the local network, well except once. There was one glimps of hope when I was able to get it flashed with v2.3 and it rebooted and did a full update over the internet. Even this time it did not ask me for the password when I connected to it’s hotspot but it looked like it was going to work. I then took both units outside and started them up. The “broken” one would only create a hotspot. I tried reflashing it many times with different cords and from a Windows machine and a Linux machine. It got to the point now that the computer won’t recognize that a USB device is connected. No usb0 on Ubuntu and when I plug it into Windows it flashes twice that something is connected but then it goes away. Below is a link to a 15 sec. video trying to show the LEDs once powered up. When reflashing with Ubuntu there are no error messages during the process but I can’t believe it is working correctly since when I plug it back in and type ifconfig I get no usb0.

Is there anything I should try?
Thanks,
Robin.

Hello Robin,

It’s upsetting you had to go through so much trouble. If I understood correctly you had no trouble setting one of them up?

Overall, this means you have the process figured out correctly and there is something wrong with your second Reach hardware-wise.

I can’t see what’s bothering you. The network SSID and password don’t change after reflashing. You’ve probably added them a while ago.

I am not sure where to start. Your main concern with the device is that it doesn’t connect to your wi-fi? Please flash it again try to ssh into it via usb.

After adding your network, check /etc/wpa_supplicant/wpa_supplicant.conf to have valid SSID/psk pair. If it is indeed vakud, try restarting and post contents of systemctl status wpa_supplicant -l.

Hello Egor,

Thanks for the reply.
Yes, it’s safe to say I have the process figured out and have done it successfully a few times.

The real issue now is that both a Linux and WIndows computer won’t recognize the device when it gets connected by USB. The video shows what it does on power up, no wifi hot spot anymore. It seems impossible to communicate to it with either USB and wifi.

When flashing from Linux, I don’t see any error messages but because I no longer get a usb0 displayed with ifconfig I don’t really believe its actually getting flashed. Mainly because there is no change in its state. I’ve tried v1.2, v2.3 an v2.6.

It seems bricked.

I will keep trying but I believe if there is no usb0 I won’t be able to SSH into it.

Thanks,
Robin.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.