Reach never get fixed

i have tested about 8 times totally .
here are the pics of showing the test i did on 16th june.
the environment of test place .

frist test .

i used 2 sets of reach . one as base connected to PC, the other as rover connect to Pixhawk . the correction date are transfered by serial ports . setting up as your document instruction.
here are some sceen dump of base for your reference .

i tried to change the parameters
for instance RTK Positioning mode, base static ;rover kinematic .
base kinematic ;rover kinematic . base static ;rover static .

tried to set the GNSS update to 5 hz or 1 hz or 10 hz
model selection 3 types as your document instructions .

here is the rover setting screen dump during the first testing

i found a bug , that is sometimes the correction from base cant be shown ,but in fact , it has been transfered into the rover .

that is the first test ,for the second test , i used the nrtip service in one reach . here is the screen dump for your reference .

the other remain the same . i also tried to change the parameters positon mode 2 AR modes . but not work .

during the second test , i encounter the first strongly fix , but last for 30 seconds only, i dont know why , i didnt do anything.
and the single is not in its best condition , but i only got float when i have the best single .
i just cant get fix , always float . i dont know why .

here are the logs . can you tell me how i can do to get fix not the ppk .
please note , everytime i change any parameters , i will hold for 5 mintues to give reach enough time to ajust .

You lost the fix because corrections stopped to come. This happened because you have configured all messages at 5Hz. You are trying to push too much information though the radio (that is not even useful) and at some point it is not able to transfer it any more.

There is no need to send ephemeris, it will only waste the radio bandwidth. Please try the following:

1002 1Hz
1006 0.1Hz
1010 1Hz
1097 1Hz

Disable everything else for now.

Also, put your tripod higher than the fence, you are hiding the antenna behind the metal bars.

Monitor the “age of differential” parameter on the status screen, it shows how long ago was the last arrived correction generated. Normally it should be <4s.


So far, I only looked at the first test:

  • RTCM3 log: lost connection 15 times. when connection lost, fix is lost.
  • rover log: poor reception until 07:52, after that it is good until the end at 08:11
  • with fix-and-hold enabled, good fix starts at 07:53 and lasts until 08:06 with about 7 base signal interruptions in that time.

I suggest to try again, but switch your rover from continuous AR to fix-and-hold AR. Also if there is a way to keep the base corrections coming in without interruption, that would help.

1 Like

ok, i will try , but i used to test in the open air , dont have fence , and the metal bars . but still cant get fix .

1002 1006 1010 1097 refers to ? base and rover are the same update rate ?

“There is no need to send ephemeris” how do i unselect it ?

in the beginning of the first test , there is a connection problem between the base and pc , but even things get better , i cant get fix anyhow .

i will try your suggestions .thank you .

It refers to settings in your picture below:

under RTK settings: update rate: set to 5Hz

Click on the boxes for message number 1019 and 1020 and all the others which are not needed

got it . thank you ~~

Dear sir i do as you said , i can get a fix thanks god and hold for a while , but when i tried it second time , i failed .

i beieve there is something connec to it that is in the rover’s status tab , it always cant get baseline , and the AR validation.

i tried to restart the base and rover , failed i tried to reconnect 3DR , failed again. tried to rester pxihawk failed again .

Baseline is zero. Looks like rtcm message are set wrong or not coming through…

i know , but in the morning , get fix and i didnt change anything , when i tried second time, it comes to this .
any solutions ? shall i put the screendump of base for you ?

Pictures of base and rover setting would be nice yes



You are not sending message 1006, which includes base coordinates. As a result your rover will never fix and baseline will be 0m.

1 Like

What he :point_up: said :relaxed:


got it . thanks !