Reach M2 - No broadcasting of access point

I have an M2 installed in a Phantom 4 pro. I have not tried to connect to M2 for more than 8 months but I flew the Drone for fun. Today I wanted to connect to M2 just to make updates but there is no way to connect to it. No Access Point, no connection via router. M2’s Bluetooth can be found but does not connect to smartphone.
Should I remove the M2 from the drone and do specific actions?

Thank you.

Hi Kostas,

Firstly, let’s see if the Reach M2 Network LED is solid or blinking.

If the LED is solid, you can connect to Reach as shown in the First Setup guide. For Android, please ensure mobile data is turned off.

If the LED blinks, the receiver is connected to external Wi-Fi. Can you see this Reach in ReachView 3 when your smartphone is in the same Wi-Fi network?

Hello Kseniia.

Unfortunately, it is only solid RED. There is no other color blinking.


Oh, I see. It usually happens if Reach M2 doesn’t receive enough power to boot. I have a couple of recommendations here:

If it doesn’t change anything, please share hardware setup photos for a closer look.

Hi Kostas,

Curious to know how it’s going! Did you get a chance to test it again?

Hello Kseniia

I am waiting for a reply with instruction (I hope) from the technician who installed the M2 inside the drone. So, I have not done anything yet.


Got it! Feel free to write me in case of updates :slightly_smiling_face:


Finally, before an hour I managed to open the body of Phantom 4 and removed the Reach M2. I plugged it to my PC via USB mini for power. I do the updates by mobile phone connection and later will try to see if with the same drone-internal cables the problem will remain.

It is fixed by firmware updating from version 26.1 to 28 & 29 beta!
Same cables.

Hi Kostas,

Cool! Great to know everything works now.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.