Reach M2: needs a power up from USB before drone powering up

One of my Reach M2 rover has this random problem : sometimes, when I turn on my drone, the 5V BEC manages to turn on the red LED on the M2 on, but it does not fully turn on (green and blue are off). I know that this might indicate an insufficient power source.
I then turn off the drone (and the M2), I power up my M2 alone using a powerbank on the mico-USB port. The M2 work normally, red blue and green LED are working (which is expected and show that the M2 works fine with a proper power source).
However, if I then unplug the powerbank, M2 turns off, and I then do the exact same power up than before : with my drone and the BEC turned on, the M2 works fine , without any help from an external power bank.

Any idea why I sometimes need to firstly turn on the M2 with a powerbank and only after this with my usual power setup on my drone, and sometimes I don’t need to do this, my drone manages to turn on the M2 without any help ?

Thanks in advance,
Baptiste K

Sounds like the M2 is pulling down the voltage on start-up (due to amp draw) to an extent where it is not sufficient.

What amperage is your BEC rated for ?

Thank you for your answer.
It’s a 2A 5V BEC, also used to power up a small Lidar (for altitude measurements) at the same time, but I made sure that the BEC 2A rating is higher than the sum both component’s average current draw (200mA @ 5V for M2, 250mA @ 5V for my Lidar)
I did not take any start-up current draw into account tho…
Your hypothesis is interesting, but how would you explain the 3rd step of the problem :

  1. M2 does not power up from BEC
  2. Then M2 turns on normally using a powerbank
  3. Finally M2 is now able to work normally using the previous BEC as if nothing happened .

Could it be an internal capacitor charged by the powerbank ?

Also, I sometimes do not need to first use the “powerbank technique”, the M2 just turns on normally with the BEC. How variable is a voltage drop caused by an amp draw ?

Yep, that would be my guess as well. So if you wait X amount of time, the cap should decharged again, and you wouldn’t be able to start as with the first.time boot.

That really depends on the quality and rating of the BEC. Some are constant voltage even, and will limit current draw instead.
I would advice to just put a multi-meter on the leads, so you can see for your self.

I have seen the same behaviour when using a standalone LiPo but I do not have any extra equipment on the circuit. Plugging it into a phone wall charger wakes it up and then it works from the battery. We have another drone that powers the M2 directly from its battery and doesn’t seem to have any issues.

I solved the problem today :
I tried to turn the M2 on using another 5V BEC (same component but a brand new one, without any other component linked to it, just Battery/BEC/JST on the M2). The M2 worked fine without the “powerbank technique”.
I tried again with the previous BEC that was on my drone and the problem was not perfectly repeatable.
Turns out it was a bad JST connector which had a small short circuit. I saw that when touching the JST on the M2, the red led would sometime fade a little bit.
When I unplugged the JST to plug the powerbank’s micro-USB during previous tests, I would then re-plug the BEC JST which could potentially make it work or create a short cicruit.
Using a new JST connector to connect the M2 to my BEC solved the problem.
I will make more tests in the next days on all my M2 equipped drones to check if it is definitely solved.
Thank you guys for your help !


This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.