Reach M+ stuck in Time Sync(Reach Plus v2.18)

com-resize Hello, I recently purchased the Reach M+ and have been trying to set it up. I followed the setup instructions and I’m facing a consistent issue.

After connecting the Reach M+ to my WiFi network and updating the ReachView App. I try to reboot the device by following:
“ReachView updater will check for software updates and will install them.
Press Reboot and go to the app! button. Wait while device reboots.
In about a minute refresh the page with ReachView app.”

My Reach M+ starts flashing the green LED as if it’s stuck in Time Sync. When I try to connect to the app through the browser by 192.168.1.x, it says that the connection is refused. After doing a bit of research I realized that my Reach M+ is getting stuck in Time Sync. Can anybody help me out with this issue? I’ve tried re-flashing the firmware 3-4 times now but without any luck.

When I try to access my device via 192.168.1.x:5000 while it’s stuck in Time Sync, it passes all the test, even the Time Sync one.

Please help me figure out a solution, thanks in advance.

Can you put the antenna by a window so it can get the time from the satellites?

Time sync comes from either of:

  • satellites, or
  • a network time server (NTP)

Hello, I tried that out as well, took my antenna out in my balcony and even pointed it out towards a clear sky but still facing the same issue. I edited my post with the GIF of the LED status. Do you have any other ideas?


Did you power off first, then take to balcony, power on, wait for solid green, then try to connect to it?

In clear sky, the flashing green should only last for a few seconds, but it can take up to a minute or two if the reception is poor. I am able to get time sync indoors, but sometimes I have to move it around to find better reception.

Yes, I followed the same steps, but what do you mean by try to connect it? Connect to the reachview app? Or something else? I get WiFi(the one on which my reach is configured) signal in my balcony and the reach automatically connects to that WiFi on power up.

You do have the antenna plugged in, right?



This is my setup, it is according to what’s recommended.

I also have a Reach RS+ module which connected properly and is working fine.

Is the Wi-Fi network your own? Or does someone else operate it (a hotel, business, commercial Wi-Fi service)?

Here are some things to do:

  1. Try going to Reach’s IP with a browser (not the ReachView mobile app).
  2. Try the same thing for port 5000 ( - substitute xxx for Reach’s IP address)
  3. Try to boot it up outside and away from your Wi-Fi network (or turn the Wi-Fi network off) so it starts up in hotspot mode. Then connect to Reach and open up in your browser.
  4. Reflash the unit

It’s my home WiFi network.

  1. I tried this, it says connection refused immediately when I try to connect.
  2. When I use the port address, I’m able to open the ReachView Updater where it shows that Time Sync check has passed.
  3. I tried this out as well, took my reach m+ for a walk, it started in a hotspot mode and got stuck in time sync, again says connection refused when I open it up through
  4. Reflashed it 4 times.

Do you think the device is broken? Idk what to do anymore. Thanks for your continued help.

Your home Wi-Fi network may have an NTP server and if your M+ picks up time from that, then it can pass time sync.

If you are out for a walk and M+ can’t see any satellites (because of antenna issues), then it would certainly get stuck in time sync because of no NTP server and maybe no satellites.

You have done quite a bit of troubleshooting. I think the only obvious thing left to do is try a different antenna (if you have one available).

If it were me, I would be go into the device and poke around to see what the hangup is. But at this stage it is probably a good idea to email and tell them you have done quite a bit of troubleshooting and link to this thread.

1 Like

Reboot your router. Try a different network name and make sure your password conforms to the security you chose. I.e. some don’t allow special characters. Make sure wifi name conforms.

If all else fails. If you have the option to default your home router to factory settings, try that.

If beyond that, email support like @bide said.

Yeah, it seems I’m doing everything right according to what you guys are saying. It can be the antenna too, is there any other antenna compatible with Reach M+ except for the Tallysman?

I had to mess with the exposure of your picture to see what is going on there:


Is the antenna on a metal ground plane? It looks like carbon fiber. If not metal, then at least put a layer of aluminum foil under the antenna. Just to test it, you could put the antenna laying directly on the roof of a car or on an upside-down metal cooking pan.

Also please confirm that you haven’t cut or trimmed the antenna cable. It doesn’t look like it, but I want to make sure.

*Techically you should still be able to recieve satellites and pass the time sync test without a metal ground plane, but the reception will be poor.

**Also, I have a feeling that M+ should be able to boot into ReachView without an antenna connected at all. Is anyone with an M+ running v2.18 willing to try booting without the antenna and see if ReachView is accessible?

Yes there have been several antennas used sucessfully. If you have something available, then you could compare specs with the Tallysman TW4721 or look directly at the ublox chip specs to be sure. If just for testing, then even a GPS-only antenna will do.

That’s why i suggest they start fresh. Looks like that ground plate isn’t proper either… make all the conditions correct per the Emlid docs and go from there.


This is what I have setup now for my ground plane. Still won’t work. And I think the Reach M+ should work without the antenna as well, at least when it’s connected to a NTP server(in my case, my home WiFi).

1 Like

Will it help, if I try connecting Reach to a phone hotspot?

Yes, you might as well try the phone hotspot too.

Can you also confirm that the ReachView updater page says that you are up to date?


Check this out. ReachView says I’m up to date.

So very strange…