Reach is not creating Wi-Fi hotspot

Hi, I also have just received my Reach units. The 1st unit is setup nicely on my network, but I cannot see the 2nd unit to setup the wifi. The unit flashes white, blue, blue, red. Do I reflash also?

Also, this link here

"Flashing Reach from GUI

Getting Intel Phone Flash Tool Lite

You can get the tool here. It is available for Windows, Mac and Linux. If you are running Windows, you will also need to install the drivers provided on the same page."

Takes you to a non english Intel site/

Hello Kyle

How are you trying to access the second unit? By IP? “Reach.local” will only work on one unit in the same network, unless you changed the name to something else during the network setup process.
Could you post the result of a network scan?

Just to clarify: this LED status means that ReachView is working, the unit is in client Wi-Fi mode. Are you sure you are looking at the device you can’t set up?

Thanks for the tip, the link is now fixed

Hi, the 2nd unit is not emitting its wifi hotspot, it does not appear on any of my devices. I have reflashed the firmware using MAC terminal and it still does not work, still flashing white, blue, blue, red.

As soon as I turned on the 1st unit it displayed its wifi hotspot. What else can I do?

How long did it take to reflash the unit? It should take about 5 minutes. Sometimes, Mac OS computers might not see Reach and abort the flashing procedure.

Judging by the LED status, it is still connected/trying to connect to a known network you entered, which is impossible after a reflash

Yes it did take a while to reflash. It wrote the new firmware, then rebooted, but I did notice that the terminal times out while waiting again for the reach.

With regard to your second comment, I have not logged onto this 2nd unit as yet so it does not know any of my networks. I have not been able to get to this stage yet of setting up my network within it as I cannot see its initial wifi hotspot.

Kyle, just to clarify - your second unit did not start a hotspot after you powered it for the first time, nor does it after a reflash?

The only outcome of this I can think of is a defective Edison.
We will contact you via a private message to discuss the best way to replace it.

I will try to reproduce this behavior and come up with a something in the meantime

Hi Egor, yes that is correct, it never came up with its hotspot. I have been trying now for the last couple of hours to reflash with no luck either. Thanks Kyle

We are trying to investigate the problem. It would really help if you connected to Reach via SSH through USB Ethernet and posted output of the following commands:

  1. ifconfig
  2. configure_edison --showWiFiMode
  3. sudo wpa_cli status
  4. sudo systemctl stop wpa_supplicant
  5. sudo systemctl start hostapd

Commands 4 and 5 will force Reach into AP mode manually, output of these is the most valuable. Also, check if it actually created an AP

Thank you for your assistance and patience!

Hi, no joy with these commands, how do I contact you directly?

Just to keep this thread updated, we have determined that your Intel Edison has faulty Wi-Fi module and will ship you a replacement shortly.

I had the problem with the Edison timing out during re-flash. At first it would get only to 20% and then the other times that it got past 20% it would then time out at almost 87%. I was using the GUI for windows but I found out that I skipped a step and completely forgot to install the drivers. Once I did that I again tried and it failed, so I decided to try on a mac and it still didn’t work. I ended up going back to my windows machine and used the flash.bat with elevated cmd and that worked.

Took more then 5mins.

Thank you Igor, I recieved my replacement today and I was able to talk to it and assign it to my network. Thanks for your prompt replacement, the faulty unit is on its way back to you.

Having a slightly different problem with WiFI. Seems to create a Hot Spot but I cannot connect to it. I have reflashed the unit several times and it seems to go through the whole process okay (takes about 5 minutes and shows 100% at end).
I think I managed to connect the Reach via SSH through a USB port and for a return on ‘configure_edison ;; show WiFIMode’ got ‘Master’ but from ‘sudo wpa-cli status’ got ‘Failed to connect to non-global ctrl-ifname (null) error No such file or directory’.

Not familiar with what the error means.

The second Reach unit went through the process flawlessly.


I configure the hotspot wifi of my asus tablet on reach. Now, The hotspot of reach is then disable and reach does not connect to my assus network!!! The led of reach is bliking in green. No way to connect again to my reach!

Do you have any suggestion?