Reach Firmware 32 Beta 3 is out

I purchased an RS3 today here in Brazil. However, I inserted the cell phone chip (sim card), and it simply kept the search symbol… and did not enable mobile data.
The same chip that used and worked in the RS2. I put it back on the RS2, and it worked right away, without any extra APN configuration. Does anyone know how this can be fixed or if it is something specific to my region? I really - and urgently - need to work with NTRIP.


Hi @joaovitorlara8,
Please send us the full system report of your Reach RS3 to Our guide will help you. We’ll take a look at it to see what could be the source of this.



I just sent the report. I look forward to being able to return to fieldwork.

Another question: does sending corrected tilt information also work for the Surpad? In the same settings as FielGenius?


We got your report. Let’s continue the communication via email to keep everything in one place.

Another question: does sending corrected tilt information also work for the Surpad? In the same settings as FielGenius?

Unfortunately, Surpad doesn’t support the Reach RS3’s tilt compensator.


Hi all!

Today, we’ve released the new Beta version of Reach firmware—32 Beta 2.

Explore the list of the major changes.


  • Consistency of the antenna height values between the base, logging, and NMEA messages settings.

    For example, if you enter the antenna height on a tab with NMEA messages and then go to the logging settings, the correct antenna height will be applied there as well. Note that if the log is already being recorded, it should be restarted for the new antenna height to take effect.

  • Tilt compensation initialization for Reach RS3

  • Tilt compensation behavior for Reach RS3 in case of low movement

  • Tilt compensation debug capabilities for RS3


  • Cases where Wi-Fi fails to reconnect to a lost network
  • Cases where the UBX log could not start correctly

This release is available for Reach RS3, Reach RS2/RS2+, Reach RS+ and Reach M2/M+.

Like the previous 32 Beta 1, this release also features the NMEA GGA and GST messages with the compensated position from Reach RS3 that allows compatibility with third-party software.

If you have any feedback on this or other 32 Beta 1 improvements, feel free to share your comments.


How can I install the beta update?
I have activated beta update channel in settings. But it still says Version 31.8 installed is the latest version?
What can I do? Is there some place I can download the beta and install it using the reach flashing tool?
Best regards

Hi Jahn,

Welcome back to the forum!

If you’ve already enabled Beta updates in Emlid Flow’s Firmware updates tap, all you need to do now is provide Internet access to your Reach. The quickest way to update Reach is to connect it to the Internet via Wi-Fi.

I have enabled beta updates in Settings->Firmware->Beta-Update
RS3 is connected to internet via WiFi.
But it states 31.8 is the most recent version and the is no possibility to load a beta version.

Hi Jahn,

Sorry for the late reply. Could you also please try to connect Reach to your phone’s hotspot and try to update it to the Beta version again?

I’m curious why the antenna height settings aren’t also consistent with the antenna height setting in Survey project?


Hi everyone!

Thank you for your feedback on the previous beta releases. Today we rolled out the 32 Beta 3 release with several fixes.


  • Tilt Compensation status notifications for Reach RS3
  • Cases where Reach firmware update was not possible via mobile data
  • Cases where no error message is displayed after a failed update attempt
  • Cases with no decimal digits in the antenna height settings on iOS devices

This release is available for Reach RS3, Reach RS2/RS2+, Reach RS+, and Reach M2/M+ receivers.

We look forward to your comments and are preparing a stable firmware release.


Something changed in 32 beta 3 that broke an existing RS3 - Field Genius Android connection that previously worked with 31.8 & 32 Beta 2. It required re-establishing a new Rover profile in Field Genius to re-connect to the RS3.
The same happened in reverse after downgrading back to 31.8, and was consistent across two separate Android devices.


Thank you for reporting!

Can you share a screen recording or screenshots of how it looks from the Field Genius side?


The error message is pretty generic.

After selecting “Connect”:

  • Get “Connecting to device”…normal

  • Then get “Testing connection”…normal. Also a little clue here because it indicates at least some dialogue is taking place before it trips over. If the RS3 is off or out of range you won’t see this and after a patient wait will go direct to the next message.

  • Then boom “Unable to Connect to Instrument”… abnormal. Twice, in case you missed the first line in the message…

1 Like

An update after some more testing.

The original issue was experienced going from 32 Beta 2 to 32 Beta 3 & back to 31.8.

As 32 Beta 2 is no longer available I’ve cycled 31.8 to 32 beta 3 and back and forth a few times and the symptoms changed and may be Bluetooth related.

Most times FGA re-connected fine, a few times it couldn’t locate the RS3 at all and I had to turn RS3 discoverability back on (it gets turned off in the update) for the RS3 to be relocated and the FGA profile to be recreated & established.

I probably now pushed my luck far enough cycling firmware updates before I brick something expensive.


Thank you, @Wombo. Just in case anyone follows this thread, we’re already discussing this case via email, and we will provide an update, once we have news.