Reach Firmware 29 update brings advanced RINEX logging and extended NTRIP protocols support

Hi everyone!

Reach Firmware 29 update is rolling out today for Reach RS2, Reach RS+, and Reach M2/M+ devices. This latest update delivers enhanced RINEX logging and NTRIP protocols support, as well as general stability improvements for the overall user experience with Reach.

New in RINEX logging

With the new update, we have added point markers into RINEX logs in ReachView 3. Now, if you collect points with RINEX logging enabled, the app records the collection events’ start and end times directly into the RINEX log for further post-processing in third-party PPK software. We have also included the approximate position in RINEX start/stop events. These improvements will help you seamlessly use the raw data from Reach for post-processing in your PPK software.

In RINEX NAV logs, we have added leap seconds output. What’s more, we have enhanced the RINEX logs’ compatibility for the OPUS preset.

One more improvement comes in the RINEX logging settings. You can now select SBAS (Satellite-based Augmentation System) in the satellite systems, which gives you additional data.

SBAS selection in logging settings

Extended NTRIP protocols and Autel drones support

For NTRIP users, the latest update supports encrypted protocols over TLS/SSL required by some NTRIP casters. This means all AUSCORS mount points are now fully available in the ReachView 3 app.

AUSCORS mount points in ReachView 3

Furthermore, we have added support for the NTRIP V2.0 protocol. This feature allows connecting Reach receivers to Autel RTK drones using the NTRIP Local option in ReachView 3.

Other improvements

As usual, the new firmware version improves the overall stability and simplifies the user experience with Reach devices. Among other things, we have delivered the following improvements:

  • Changed device naming restriction: the underscore character _ is forbidden to follow the standards of the correct device’s hostname in the network. If your devices’ names have underscores, they will be automatically renamed to the title without underscores (e.g., RS2_Base → RS2Base).
  • Added the 14 Hz rate selector for the NMEA position output on single-band receivers.
  • Improved battery charge estimation on Reach RS2.
  • Increased stability when working over external LoRa on Reach M2.

Complete list of fixes and improvements

Here is the complete list of changes we’ve implemented in this release.


  • SBAS selection added to the RINEX logging settings
  • Point markers added to the RINEX log when collecting data with ReachView 3
  • Approximate position added to RINEX Events
  • Leap seconds output added in RINEX NAV logs
  • RINEX logs quality improved for the OPUS preset
  • NTRIP V2.0 added to the NTRIP local caster option
  • Encrypted protocols over TLS/SSL supported for some NTRIP casters
  • Restriction added for device naming: the underscore character _ is forbidden
  • 14 Hz rate selector for the NMEA position output added on single-band receivers
  • Battery charge estimation improved on Reach RS2
  • Stability improved when working over an external LoRa module on Reach M2


  • Epoch seconds overflow in RINEX
  • NMEA timestamps for midnight
  • Cases of the raw log being suddenly restarted
  • Issues with unavailable log files
  • Raw data debug setting for logging
  • Stop recording logs if rolling logs is disabled and no space is left
  • Solution logs file extension being always LLH
  • Cases of the LoRa frequency settings not applied due to regulatory restrictions
  • Getting NTRIP mount points for some casters
  • Issues when it’s impossible to update base mode RTCM3 settings with NTRIP selected as base mode output
  • Cases of the receiver stucking in loading
  • Cases when devices with the same names are not visible in ReachView 3
  • Representation of the current GSM modem mode for Reach RS2 receivers
  • Alignment of the Base corrections label on the Logging tab
  • Hint placement about RINEX header for Reach RS2 in the raw log settings
  • Faded Updates section on repeatedly opened Updates panel
  • Wrong Bluetooth device name representation
  • Typo in the name of the sdun column in *.POS file

Where does one find the update and instructions?

Hi Daniel,

You just need to connect your Reach to the Internet to get the ability for a firmware update. If you need detailed instructions, please take a look at our How to update firmware guide.

Perfect! Thank you very much!

1 Like

Sorry for the topic in my first post. After the update and restart, RS2 was working normal. I shut down the reciever. A couple of hours later, after pushing the start button, the RS2 is in “loading mode” (power indicators blink from left to the right). What is your advice to solve the problem?

7 posts were split to a new topic: The distance is missing during the stakeout

I will have to update the shortly. I have some rapid static files from the last few days that will not adjust to nearest second via Emlid Studio 1.2. What’s odd is that I could do this with studio 1.1. Even with the new checkbox for OPUS, it’s not rounding properly. I don’t like to set the pre-defined opus logging on the base because then if you want to submit to another service like NRCAN, The interval and satellites observed are not sufficient. When doing any static work, I like to do one second (1hz) with all constellations and decemate with Emlid studio if need be. Can someone test this amount studio. I tried a couple of different rinex files and no matter what setting I try, it will not round to the nearest second. Please confirm if this is a bug in the latest Emlid studio.

Solved withrs2 flash.

1 Like

Hello all,

We updated our M2 to firmware 29 final, and the green LED light not become solid (keep blinking) but we could access and use it like normal. Is it the new change or something could be wrong?



After a few times restart, those M2 did not start, only the orange LED light was solid, the blue and green LED were off completely and we could access it via ReachView 3 app.

Does anyone have this issue?


5 posts were split to a new topic: Missing triggers on M2

I reflashed the units using PC and it worked fine again. So, something went wrong during online update by itself.


Hi Ivan,

Welcome to the community!

I agree with @ffcb, please reflash your device according to our guide. Please note that this procedure will remove all of the stored data (logs, system reports). Please let me know if it helps!

Hi Zach,

I can see that you have already checked this out in Emlid Studio thread. Just to conclude here, to apply the rounding of the seconds in the Studio, you need to convert the UBX file to RINEX for now.

1 Like

HI @l3technologycambodia,

Thanks for your report! Good to know that the reflashing procedure helped. We’ll investigate what could have gone awry during the update for your device.

1 Like

A post was split to a new topic: Roll back to a previous version

A post was merged into an existing topic: Roll back to a previous working version

A post was merged into an existing topic: Roll back to a previous working version

Hello everyone!

Today we’ve released a new Reach Firmware 29.1.
It contains a fix for some issues related to hanging in the “loading state” after the update


Hope it Fixed the M2 issue I reported above. Will try it. Thanks

1 Like