Reach does not go from single to float

Dear support team,

I finally got the 2 reach modules working and also got nice RTKplot connection. The problem is: only single, no float.

base is setup at 1.5m height
rover is setup at 2m height
distance between rover and base: ~5m


  • 10m away from base is a building with 8m height.
  • 5mway is a jung tree with 6m height

As you can see from the images: there are 4 or 5 green bars the corresponding grey bars are not always above 45% level.
no in the evening (it is now around 22:00) I got 6 green bars, 5 of them have grey bars above 45 level.

I run the setup for more then an hour, RTKplot result:

It seams hard to get sat over 45 level. I can i adjust the level for green from 45 to 35 (somewhere in the adv settings: snr ask, elevation mask,…)?
Do I need a better antenna for such an easy situation?
What do I make wrong?

here are some images:
Base on a tripod:


web view:

Dear support,
I realized one error in my configuration: i do not used the glonass sats!
I activated the checkbox glonas but I used GPS_10hz instead of GPS_GLONASS_5hz.

after I have corrected this I got 8 (!) green bars!!!
but I am still waiting for float…


There support,

My actual status screen looks like this:

I have a lot green bars but there are much less grey bars. I also can observe that some grey bars appear and leave very often…

only single, no float or fix…

with best regards

If the grey bars are appear and disappear, then maybe there is trouble with the communication link. So try slowing to 1Hz and see if that makes any improvement.


I found the issue with the jupping grey bars: There where not grey bars for the Glonas sats. Then the sorting changes and it looks like that some bars appear and disappear.
configure the base so that the rtcm3 messages include glonas: 1010

Now the situation is:

Single: yes
float: no
fix: no

what do i have to do next?

Emlid team: please add this to the help section more clearly (RCTM messages needed are:…)

with best regards


Try adding all RTCM messages. How did you set the base coordinates?

Dear @egor.fedorov,

thanks for the response.

I tried for 30min: only single
Then a changed the RTCM messages to all label.
I tried at least 30min: only single
–> no change:

As you can see there are 6 green sats and 5 of them have grey bars above 45 level…

ad base coordinate:
I just let the reach run and read a coordinate and use this as the coordinate for the base. this means that the coordinate has an error of around 5 to 10m. This means the float will be not perfectly accurate. But there should be a float isn’t it?

what else is going wrong?

with best regards

What is happening is not intended, and there must be some error in the configuration. Would you mind posting the base config screen?

Dear @egor.fedorov

here is the base config screen:

here is the rover config screen:

here is my actual status:

with best regards


Could you please try dropping setting to default and trying again? (in menu with 3 dots you can revert to default)

Could you please post a raw log file of that 30 min attempt?

Dear @igor.vereninov

I have done reset to default. I have unpluged the 3dr radios (I never get those to work, this is an issue for later). This last action helped to bring one of the reach back to work. The problem was that the after pressing save or start it wont start.

I now have both running in single. I can send a log file from one of them. the other log file could not be downloaded.

Then I tested a local NTRIP Server: I got float after 1min! fix after an other minute!

Then i tried normal base and rover config over tcp and there was no float or fix!

with best regards

This is a very interesting observation, we will try to reproduce the error.


We’ve discovered the issue. Seems that in the latest version there was a mixup of latitude and longitude labels in the Status tab. As a result, you have entered wrong coordinates to the base and this prevented Reach from getting a float or fix status. We fixed the mixup in version 0.4.2 and encourage you to update.

As for the base settings, in your case swapping latitude and longitude values will suffice.

Thanks for the report and sorry for the inconvenience.

Dear @egor.fedorov

Perfekt! I now have float after 20sec!!
That is big progress for me!

thank you and best regards

1 Like