Raspberry 2 realtime kernel image

I would prefer the source code:) It could be really useful for a lot of researchers.

hi @vincenzocalabro looks really cool, I am looking for an option to use ROS to extend my rover’s capabilities with computer vision for especially object avoidance.

indeed any change you can share any of your work? or some guide or documentation on how it is done?

would be really appriciated


putting ROS on a Raspberrypi can be done I have limited experience with ROS but your package to use the NAVIO sensors in ROS look intereseting, could it work together witn APM autopilot?

I am thinking about a layered system were the autopilot sets out the high level goals (waypoints) where to go and ROS would figure out the details between waypoints how to get there… handeling stuff tht is in the way etc etc…


Ehi Hugo,
I’m working in that. Soon I’ll release an image for RPi 2 with ROS and Qt5 and some of the Navio sensor modules. You should speed up your development with that :smile:

I’ll post something asap.


that would be great Vincenzo…!
Cant wait, i have ordered a RPi2 so I can run ROS stuff side by side with NAVIO


Hugo, if you want to use ROS with APM then probably MAVROS would suit you better.
It uses MAVLink to receive orientation data from the APM and can control it by setting new waypoints etc.

I am having trouble getting my RPi2 to boot with the RT image. I have tried several times formatting SD card, adding image via Win32DiskImager, then putting SD card in RPi and plugging it in. Is there a step I am missing here? I had the original Raspbian image installed from NOOBS and that worked fine.

Thanks for your help!


Did you unpack the image first?

No, I guess not. So unzip with 7Zip then write the image?

Yes, that’s a correct order.

That worked! Thanks.

Has anyone had problems with serial on the RPi2 with the realtime image?

I have a microcontroller that reads RPM and sends it to the Pi over serial using the wiringPi library. Using a RPi B/B+ and the realtime image from Emlid, everything functions as expected. When I moved to the RPi2, the serial no longer works. The oscilloscope shows both TX and RX at a steady 3.3V. The only thing I did when I moved it over to the RPi2 was recompile the code. As a test, I used the Raspbian image provided by the RaspberryPi foundation on the RPi2 and the serial works as expected, so it seems that something about the realtime image is causing the serial to not function properly.

I am successfully using serial telemetry with ArduCopter. Have not seen any issues like you describe.

I just Downloaded Raspberry pi real time image from the website. I have few questions. I see it loads to the console. does it come with any graphic interface. if so how to access it ?. Also, what is the default root password. if it can be access it. my last question is that I was trying to compile a c++ program but it was failing (using nano to write the code) it was a simple hello world c++ but when i type quotes it shows the @ symbol and when i try #include . it gives me another symbol instead of the #.
Thanks in advance.

The default password is the same as the default Raspbian password, that’s user name “pi” and password “raspberry”.

The additional setup is already documented here:

There is no setup GUI so far as I know. You can install the desktop GUI but that is not recommended for drones (waste of resources) and won’t bring much as most of the configuration is done via APM/Ground Control software once you have the basic scripts and configuration files setup correctly.

Things to do are roughly:

  1. If you are using WiFi then configure that. You may have to read about WPA supplicant or other articles if you want to get WPA2 working. If you don’t intend to fly with WiFi (some people use that instead of FPV video, telemetry radio and some even instead of the RC receiver too).
  2. Download and install APM, but you probably want to follow the instructions to download the 3.3 release because the APM.DEB has not been updated and the 3.3 version is now produced directly by DIY Drones. It’s currently in “beta” phase. You can follow these instructions to get it:
    APM 3.3-rc9 beta testing - #23 by CodeChief
  3. Run APM (and usually add it to start-up too by editing “rc.local”). Connect to it’s IP address with your chosen GCS (e.g. APM Planner 2 or Mission Planner) and complete the configuration (skipping the “download firmware” part because the firmware download is replaces by the program you just downloaded in Linux.


What is the status of the USB FIQ driver, has the conflict with the rt patch been fixed or is it going to be fixed?
It seems there are also some problems with the rt patch and the non-FIQ driver (poor network performance)…



I’ve been trying to meed Mavros with Raspberry pi using Navio+, however I´ve spend some days without any results. I’ve been using raspbian with the image of cctronics, the question is if have you ever installed Mavros on raspbian?, could you give me any suggest?.

@CO_OL I’m afraid I cannot help you with the cctronics image as this is not our development. One of our users managed to install ROS Indigo on our image for Navio2:

Thanks by support, I will try with the link provided, best rgds.

Hi I have a RPI2 model B+ and I was trying to download this, but the link is broken is there somewhere else where I can download it, or another image for the rt kernel that i can use in my RPI2?