Radio control is not active or turned on

I am in the process of setting up my Navio 2 board. I have managed to connect with APM Planner and configure the compass, accelerometers, etc
I am using this 3dr PPM encoder:

I have connected the encoder to the PPM pins on my Navio 2 and the Rx. The encoder itself looks to be working fine. The LEDs indicate that it picks up signals from the Tx when I turn it on, and the blink rate on the encoder increases as I throttle up as it should.
So the signals from Tx → Rx → Encoder seem to be working as they should

However, when I connect to APM it says “Radio control is not active or turned on”. So the Navio doesnt seem to be receiving any radio signals.
I have on occassion seen my radio signals display at neutral values on APM Planner (mid throttle, pitch, yaw, etc) and as soon as I turn on my radio Tx the signals seem to drop out to null or zero values.

I initially was powering my Navio through The Pi’s USB power. But I decided to instead try and power it using a battery via the power module. I get the same behaviour.
I also tried connecting using Mission Planner as some threads in this forum suggested APM Planner was the problem. But I receive a similar error using Mission Planner too.

Does anyone have any tips about what might be happening?

As far as I know, APM for Navio2 is not ready yet. Navio2 uses a dedicated processor for RC Input, which is not supported in the current APM version.

That makes a lot of sense. Last night I stumbled across the new Navio 2 documentation and the comment on this page made me think that maybe it could be a software thing.

I notice that there is a notice up there now that says APM package is delayed for a couple of days because of bugs. I wait with anticipation.

A bit weird the hardware was ready and shipped but software not without a note to the customers informing them of that fact. Could have saved me quite a bit of debugging time.


We sincerely apologize for the delay and for not providing a timely notification. We have now published it in the docs. The software stack for Navio2 is sophisticated and we are are working very hard to deliver support as soon as possible. Doing our best to release before the weekend.

I appreciate your reply Igor. And appreciate the work to get the software out to keen punters like me.

The Navio 2 looks like a really nice product. So very much looking forward to seeing it get airborne. I have my fingers crossed that you and your team see green tests shortly and I’ll post my maiden flight photos from the weekend here as a thumbs up to your success. :smile:

Let me know if you need any help with the documentation. I can maybe post my experiences for things I figured out along the way that might be useful to add.

1 Like

Hi Ivan. Did you and team have luck in resolving the defects you found prior to the weekend?
I notice there is a fork and PR to the Ardupilot code that is in Github here: GitHub - emlid/ardupilot at pr/navio2

Can I compile from sources on this fork right now? Or are there still issues with the code in that fork?
Also, will there be a completely new Raspberry Pi image required? Or, will the Pi image here still work?

Hi Bradley, from what I’ve tried here the pwm driver is not yet available, or I couldn’t find it. That was the error I got using the fork you linked.

We have just published download links to apm package and raspberry pi image. You can find them here.


Thanks! That download is crawling though. Looks like it’s gonna take me 5hrs at this rate. Are there any mirrors?