Emlid

Community Forum

Problems installing APM on Rpi


(Info) #1

Installation using sudo apt-get install apm-navio2 fails but also sudo apt-get update fails with a few erros on missing files.

Trying to compile from source encountered this problem:

pi@navio:~/ardupilot $ waf copter
Waf: Entering directory `/home/pi/ardupilot/build/navio2’
[4/4] Processing modules/mavlink/message_definitions/v1.0/ardupilotmega.xml
/usr/bin/python: can’t open file ‘/home/pi/ardupilot/modules/mavlink/pymavlink/tools/mavgen.py’: [Errno 2] No such file or directory

mavgen returned 2 error code
Waf: Leaving directory `/home/pi/ardupilot/build/navio2’
Build failed
-> task in ‘mavlink’ failed (exit status 2):
{task 1985868064: mavgen ardupilotmega.xml -> }


(Info) #2

and this is the error running sudo apt-get update && sudo apt-get install apm-navio2

W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://files.emlid.com jessie InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY D2D4790B01F8D571

W: Failed to fetch http://files.emlid.com/debian/dists/jessie/InRelease

W: Some index files failed to download. They have been ignored, or old ones used instead.
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following NEW packages will be installed:
apm-navio2
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 5,771 kB of archives.
After this operation, 12.3 MB of additional disk space will be used.
Err http://files.emlid.com/debian/ jessie/main apm-navio2 armhf 3.4-rc1-20160609
404 Not Found
E: Failed to fetch http://files.emlid.com/debian/pool/main/a/apm-navio2/apm-navio2_3.4-rc1-20160609_armhf.deb 404 Not Found


#3

Dear Emlid Team,

I can confirm this, I have a similar issue. Somehow, the deb file seams not to be available on the emlid server.
Also if I try to do a wget http://files.emlid.com/debian/pool/main/a/apm-navio2/apm-navio2_3.4-rc1-20160609_armhf.deb, I get the message “file not found”.
I think this is an important issue as we are not able to install the software unless we compile it from scratch.
Thanks a lot!


(George Staroselskiy) #4

Guys, take a look at this thread. This will solve your issue.


(Alriks) #5

George,

When you try to follow the link to the thread, you get this message:

:frowning:
Access Denied
while trying to load /t/id_for/new-emlid-raspbian-stable-image
Something went wrong.


(George Staroselskiy) closed #6