Problem to get Fix after Firmware Update

Since the update to version 29.2, we have had problems getting a fix. Before the update, it worked perfectly. The device is used with a sim card. I also noticed that since the update I’m only getting 2G and before it was 3G network. I hope someone has a solution and thank you in advance for your suggestions. And is it possible to go back to version 28.4?

Hi Ömer,

Do you work with an NTRIP service? Do you receive Single or Float?

I also noticed that since the update I’m only getting 2G and before it was 3G network.

Most likely, it was always 2G. But we had issues with the representation in the interface. Since 29, it was fixed.

We don’t recommend going back to previous versions as it can hardly help. It may look like the issue is related to the firmware, but in most cases, we’re able to solve it with the correct settings.

Sometimes, there are indeed some firmware bugs, but we’ve tested 29.2 and didn’t notice anything wrong related to NTRIP. Even if so, we’ll solve this issue for you one way or another.

Hello Sevtlana,

yes we’re located in Germany and therefore we’re using our local NTRIP service SAPOS. In the past we had no problems while using a SIM card (provider: Deutsche Telekom). Almost everytime we got an instant Fix solution. Furthermore we had always an 3G connection before the firmware update. Afterwards we just could get an 2G Connection and a Single solution.

We noticed that when the Reach RS2 is connected to our Wifi in the office we get an instant Fix solution. But if we switch to mobile data via SIM card we only achive an Single solution.

After checking all our settings and flashing our Emlid device we still couldn’t get an Fix solution via SIM.

Shall we provide you with any logs or other data to solve this problem?

Thanks in advance!

Hi Ömer,

Hmm, I see. So, at this stage, I indeed need to check the Full system report from your unit. Please send it to I’m asking to do that via email as it contains sensitive data.

Hi there,

The issue was resolved by applying the correct APN in the APN settings.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.