PPM input not working

Hello, I have the same problem here. I already tested 2 different Raspberry Pi’s, a Model A and a Raspberry Pi 2 Model B, both with fresh SD cards and I don’t have any RC signal. Something different from the other guys is that I don’t have the “No pigpio interface for RCInput”, but when I run the Barometer test very weird vales are being returned:

$ python Barometer.py 
Temperature(C): 1.6134225647 Pressure(millibar): 707.102777376
Temperature(C): 32.6311831474 Pressure(millibar): 763.055305654 
Temperature(C): 35.8957379341 Pressure(millibar): -889.025814498 
Temperature(C): 35.8970854759 Pressure(millibar): -304.975798015 
Temperature(C): 35.9069899082 Pressure(millibar): 563.852119829 
Temperature(C): -544.2675 Pressure(millibar): -124.304146528 
Temperature(C): -321.133102542 Pressure(millibar): 256.610844003 
Temperature(C): -81.3988671425 Pressure(millibar): 568.523845701 
Temperature(C): -7.47396583825 Pressure(millibar): 691.315183429

I wonder if something is wrong with my Navio+ board.
I’m starting to think about buying a replacement…


I found that if I load a new SD card and run updates using apt-get update; apt-get upgrade and/or use raspi-config this would happen. Did you happen to update the system packages?

1 Like

Thank you for your answer, yes I did, at least I executed app-get update and raspi-config.

I started again from scratch, just wrote the image to the SD card and installed APM, the Barometer test now shows normal and coherent values, unfortunately the PPM input is still not being detected.

Running the PPM C++ example, the initialization runs just fine, but no input is ever detected, the function ppmOnEdge() never get called.

Any further thoughts?


What PPM receiver are you using? Are you sure that there is a PPM signal at all?

If you hook up a scope, you can verify that there’s one.

Hello, I tried 2 different receivers, one is a Walkera RX705 with a Data Bus Port (PPM compliant), the other is a normal PWM receiver, connected through the original 3DR PPM encoder, both with the same results.

I wish I could have an scope, unfortunately I can´t have access to one at this moment.

Is your receiver getting power? Navio+ will not power it, unless servo rail is powered from a BEC or ESC.

Thank you Igor for your answer, yes it is getting power through a dedicated BEC.
Even the blue Led of the 3DR PPM Encoder is blinking faster according to the throttle position.

I just hooked up a scope to the output of both the receiver and the 3DR encoder, here are the readings:

This is the 3DR PPM Encoder:

The output voltage is 5V, and the signal looks fine

This is the signal from the Walkera Reciever’s DataBus:

The signal looks ok, but in this case the output voltage is 3.3V

Is there any point at the Navio+ board where I can hook up to measure the signal in order to see if it is getting through?

Thank you guys.

This are the signals with the encoder connected to the Navio+.

Channel 1 is the encoder’s output and channel 2 is GPIO04. As you may see the output of the GPIO04 is constant at 3.3V

Any thoughts?

There is only IC10 - NTS0102GT logic level converter in the way of the signal. Can you visually inspect it? It is located near servo connector. Could you by any chance have made any modifications to the board that would affect it?

Visually it doesn’t seems to have something, and no, I didn’t made any modifications to it.

@JorgePi Just sent you a private message to arrange a replacement. Sorry about the incovenience :worried:

Hi, it seems I have the same problem on Navio+ and RPI2.
As a PPM generator I had used arduino nano with 5v output. On oscilloscope I see proper PPM signal and on Navio’s GPIO4 I see stable continuous +3.3v. I also played with different signal frequency to Navio’s PPM input f.e. 1sec HIGH and 1sec LOW and see the same continuous +3.3v on Navio’s output. IC10 is also on his place. PPM decoder started but no output as logic level always “1”. So, it seems it is hardware problem. May it be that IC10 (logic level converter?) has been burned someway. What this can be? Can I fix it myself?
P.S. I have checked the RPI by connecting DSO Quad’s signal generator wires to GPIO4 directly and see GPIO input on raspberry, also with signal generator Navio’s PPM decoder showing something as there is level == 0 condition and signal generator produces 0 level.

Output from PPM generator, it is proper 22.5ms signal with Vmax up to 5v:


Testing GPIO4 output:

GPIO4 output:

It looks like you have done a good job on debugging the issue. Could you send me a PM with your order number so that I could help you with repair or replacement?

Ouch! One of the 3D print housing for NAVIO+ that is show off in this forum has fat feet on the cover and squash my IC10 from PCB:-( I have been trouble shooting on R/C signal loss and found the picture above that is very odd place of the chip!
Anyway, I would like to use my NAVIO+ again.
Is it possible to ask to repair my NAVIO+ or purchasing NTS0102GT chip ?


These chips can be found on electronic parts online shops such as Digikey / Mouser:

If you don’t have a hot air gun or don’t want to replace it yourself you can ask for help in any local mobile repair company, should not take more than a couple of minutes.

Yes, thank you for the information.

I’ve just order the chip on Digi.
One thing to make sure, could you show the direction(pin1) of chip of IC10?
My chip is completely removed and gone, and no way to find pin1 position.

@Jiro_Hattori here’s the picture:

Thank you for photo. Actually, I can manage to solder the chip with solder paste and hand iron and NAVIO+ is back again:grinning::grinning: