None of the lights light up (Reach M+)

I know its not the cord because it charges my phone but when i plug it into the Reach none of the lights light up

What are you plugging the M+ into? You need to make sure it is getting enough power to boot up. I would try a different power source and also try another Micro usb cable.

What model of phone so you have?

So i can compare charging specifications.

sorry for the wait. I’m plugging it into a Powered USB hub. I know the cord isn’t bad because it still charges my phone at a good speed i also tried another cable with no luck. I used it for a year and it worked fine it’s just decided to quit now

Samsung Galaxy S7

Ok two more questions how long is the cable?

I ask this because with the newer M2 everyone is having issues with long cords and cords made with the minimum wire size.

What is the charger? How many amp? Is it a computer port?

it is a powered usb hub. I’ve been using it this way for a year and it was working fine. im using the same cord and usb hub on an m2 and its working fine

The Cable is 9 ft Long

If it will power the M2 its should be fine.

I am not sure whats going on with your M+?

All i can think of is to look in its usb port with a light to see the condition of the emlids conductors.

Other than that i am at a loss


Please try the other micro-USB cable just to be sure that this is not the issue. Do I get it right that your M+ was working with this USB hub and micro-USB cable for a year?

Yes it was working for a year. ive already tried this cable on an m2 and it works


It would be really great to check another micro-USB cable with the M+ particularly if that is possible. It will help us to eliminate the issue with the micro-USB cable from the equation.


Have you had a chance to test the M+ with another micro-USB cable?

yes we have tried different cords, differnt power sources. no lights


Thanks for the information!

It’ll be easier to discuss the next steps in a private chat. Please check out my message in your PM.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.