No Wifi after reboot of RS+ unit

Hi,
I have a serious issue with one of my RS+ units, running 2.14. Each time I reboot it, wifi is not available. The blue LED is simple not lid, and it doesn’t create it’s own wifi nor connect to either phone hotspot or usual wifi.
If I wait 5-10 minutes and then boot, then all it does connect to my house wifi, but I can’t get it to connect to my iphone hotspot any longer.

Besides the blue LED not being lit, the issue shows itself during boot, where the orange LED is on for 30 secs or more, no other LED lit in that timespan.

Things I have tried:

  • Downgrading to 2.11.3, done this twice, problem persists
  • Upgrading to 2.14, done this twice, problem persists
  • Different and no wifi’s available.
  • I have powercycled the device around 40 times today, every time it do the cycle within 5-10 minutes, I get this issue.
  • Powercycling (reboot & shutdown) through the app does not provoke the issue, but if I loose wifi for some other reason, I am screwed.

I haven’t had this issue before, and my other RS+ unit doesn’t do this.

@igor.vereninov & @dmitriy.ershov , any ideas?

I lost a days work trying to get this thing to work again, and I have lost a massive amount of faith in the product, I must admit. Hope to regain it asap.
I would like to pull out the log, but as I can’t access the unit when it happens, I am a bit troubled there.

1 Like

Dude, that SUCKS.

From the standpoint of the NON-PLUS previous model, “if it ain’t broke, don’t fix it”? (But I guess they really had to replace the Edison processor).

I hope everything gets ironed out and you regain your faith. Such a great product.

I have the same issue. Power on RS+ now WiFi and LEDs keep blinking RED, Blue, Green as loading status show in this link https://docs.emlid.com/reachrs/led-status/

I power on/off 50 times and still not work. I use zenmap to scan and fine nothing.
Is there a way to connect to Windows PC to see what’s going on there?

Have you tried waiting ~10 minutes before rebooting?
For me it is intermittent, but very frequent. Sometimes I have to wait 5-10 minutes, other times it just works after a reboot.

wait for ~10 minutes? That’s a long time. I didn’t wait for 10 minutes, but I keep power off/on and sometime it works. However, most the time it doesn’t work!

It is indeed way too long for any practical use, when in the field. But for the purpose of checking if your problem is the same as mine, it would be nice :slight_smile:

Oh, another question, did you have it connect to a phone hotspot, when it first occurred?

I connected to my Wi-Fi Hotspot and upgrade software on the RS+ before I got into this issue.

So phone WiFi involved?

No, the device with WiFi hotspot, not phone hotspot.

1 Like

Hi @wizprod and @amy.tran,

Thanks for reporting this issue. Christian, I’ve PM’d you some additional questions.

Amy, once we look into the issue, we’ll post the update in this thread.

1 Like

I have the same problem. Sometime it is working after booting and sometimes I have to reboot again and again until it connets with the wifi.

I think Reach RS should try to connect to the stored wifi at certain intervals, for example, when after 5 min. there is no connection via bluetooth and the own hotspot, it should try it again.

In the end, it must be ensured that when a stored network is within reach, it will also be connected to it. The emergency hotspot must not remain switched on until the Reach RS is restarted (especially important for base stations)

1 Like

While I can’t say for sure, I don’t think that it is related. I am getting it outside, inside, in the shade, in the sun, in very windy conditions…
My temps have never been above 33 degrees while using the unit (not charging).

@timd1971 These are very different things. Please do not mix issues, the assumption about “workaround” is not correct.

No problem Igor. Just exploring an additional avenue to systematically rule things out in case it wasn’t thought about. (the “waiting” part of the problem suggested this) But I do understand your statement and I see that Christian now states he is NOT having heat issues… so that is OBVIOUSLY good.

EDIT: I deleted my initial post so not to exacerbate the problem. ; )

Just a follow-up on this one:

After a team-viewer session with Emlid devs and sending reports to Emlid, the unit was replaced by a new one (and the old send back for debugging), and now I can enjoy RS+ wifi again :smiley:

Thanks for the help, @igor.vereninov !

1 Like