No Solution in RTKPost QT Emlid


I am processing a RS2 four hour observation in RTKPost QT using data from an OS station about 500m from the base position. It’s GPS and GLONASS only so no other constellations selected. I’m using combined and very quickly shows Q=1. It runs forward then backward and finishes without error but the pos file has no solution. If I select “all” rather than “single” in the output tab I get a result for all the observations, it just doesn’t seem to be averaging them. There’s a few cm difference between all the fix solutions, so I could average them manually, but no idea why I can’t get a single solution - any ideas? I’ve tried just using various time ranges within the observation time, but still no position in the pos file.

I should add that I logged RINEX 2.11, and successfully processed a control point with a six minute observation using another RS2 with the same OS observation file. The OS station provides only 30 second data hence processing my own base to PPK the P4RTK drone data. If the worst comes to the worst I can do another observation tomorrow to get a position fix then use today’s observations for PPK.

Would it be possible for you to post the data here?

Yes, I will this morning. I’ve downloaded the 24 hour OS Net RINEX file and going to convert the UBX file from the RS2 and give it a go with them. I did notice it drops to a single solution around 12:18 which radically affects the averaged solution, so it might me due to that. If I average all the observations and compare that to the average of all the fixed solutions, there’s over a meter difference on the height.

1 Like

I’ve reprocessed omitting the time with the single solutions and it successfully outputs a fixed solution. You can have a look at the data here, it appears there’s a lot of cycle slips around that time, and the sat count is very low.



It seems you have logged in 5 hz or more. Have you tried decimating to something like 5 s intervals for your static obs ?

Hi Christian, yes I log at 5hz as the observation is also used to PPK the drone data which needs a high rate. I have never had an issue with this workflow before (I’ve done it dozens of times) so never needed to decimate the observation log. Today I processed the time span between 10:05 to 12:05 and the solution was good, I needed it to process the flights using RedToolbox. Interestingly RedToolbox (2.77) wouldn’t process with the RINEX observation file, I had to use the ubx then it processed without issue with Q=1 for all 760 cameras. I wonder if the RINEX file is corrupt or has bad data in it?

I don’t think that more than 1 hz would do you any good, atmospherics simple don’t change that fast. The quick interval need to be in the UAV.

Just processed in it EZSurv. Don’t get all epoch solved, but 96% or so gets solved. Good enough.
You can just grab the position while only showing q=0.

You have 2 complete outages at around 12:15 and 12:25, that is you problem as I see it.

Thanks for that. I wonder what caused the outages? Possibly could have been a large vehicle parked beside it at lunchtime but it had a pretty clear view of the sky. Thanks for taking a look, I’ll lower the observation rate to 1Hz next time, it will process a lot quicker anyway!

I processed with 5s interval, went just fine!

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.