No height data using QGIS with RS2 NMEA correction output via TCP

Hi,

We’re setting up a Fusion5 Windows 10 tablet to use QGIS linked to the RS2 rover over TCP (using the RS2 hotspot). Our units are running the latest Dev build (2.21.2) and QGIS 3.4 LTR connects fine using the GPS panel. Problem is we’re only getting the lat and long coordinates and no height, any ideas?

The plan is to develop a solution that converts WGS84 from the rover to ETRS89, then transform the coordinates to OSGB36 using OSTN15 and the OSGM15 geoid.

Thanks,

Rory

1 Like

Hi Rory,

What’s the firmware version installed on your Reach RS2 device?

Hi, ReachView is 2.21.2, how do I find the firmware version?

Where are you not getting the LLH? From the GPS panel or in attributes table of your captured entities’ layer?

In the second case, just make sure this wouldn’t have been overlooked: if the layer hasn’t explicitly been created to handle 3D position, it won’t accept Z coords and they will be absent from geometry.

2 Likes

Are you wanting to transform on the fly?

Hi, yes it’s in the GPS Information panel that the height is missing, and subsequently the active vector layer (with Z value enabled). I’ve attached two screenshots of the QGIS GPS panel and the Reachview app.

gps%20panel

The plan is to do this on the fly, it’s part of a project that I’m planning for the college computing and construction students.

Hmm, that’s something I haven’t encountered. Someone else will have to step up. :confused:

I am not sure if QGIS is able to transform ellipsoidal heights to orthometric heights by way of a geoid model.

You can load FieldGenius 10 on the same tablet and load up your specified geoid to confirm everything works.

Matt

Hi Rory,

May I ask you to check if Reach outputs the altitude in the NMEA stream using the Putty software? Please follow these steps to accomplish it:

  1. Setup TCP output in ReachView
  2. Run PuTTY.exe
  3. Choose “Telnet” connection type
  4. Specify the IP address of Reach RS2 device and the port as in the ReachView
  5. Hit “Open”

It’d be nice to get a screenshot of the NMEA data stream to check it.

Hi,

Here’s the telnet output and a few other screenshots of the issue. The unit is outside with a much better sky view than on the windowsill.

I suspect it’s something to do with QGIS as the height shows up perfectly in FieldGenius:

More investigation needed - thanks for the help so far :slight_smile:

Cheers,

Rory

2 Likes

Hi Rory,

According to the screenshots, Reach is outputting the height in the NMEA stream.

I’ve tried to reproduce it and configured the position output from Reach to QGIS. QGIS indeed doesn’t show the altitude.

Reach handles ellipsoidal height, however, I’ve noticed that the field “Altitude” in QGIS is dedicated for geoid value. So, as it was mentioned above, I assume that might be a reason.

Have you tried to reach out to QGIS support? I hope they might be of much more help in this question.

2 Likes