New Reach Firmware 30 improves Reach compatibility with other receivers and software

Today we introduce the Reach Firmware 30 update. In this release, the main focus is on Reach receivers’ compatibility with third-party equipment and performance improvements.

Improved compatibility with third-party brands over NTRIP

We have added leap seconds to the data streamed by Reach receivers acting as a base station. This helps you to seamlessly connect your Reach base with a wide range of third-party receivers over NTRIP. Now, even old versions of GNSS receivers are capable to maintain a steady FIX solution when connected to the Reach base station.

Improved RINEX logging

The recent update improves the compatibility of RINEX files for post-processing in third-party software. You can now use Reach logs for PPK in your preferable software with no trouble.

In the RINEX logging section, we have also updated the IBGE preset to contain GPS and GLONASS satellite systems. Find out how to get precise coordinates with Reach using the IBGE service in our Docs.

Enhanced interface

With this release, we introduce the renewed responsive interface in the Emlid Flow app and Reach Panel (the browser version of your survey app). In Emlid Flow, you will enjoy refreshed screen views. While Reach Panel has been completely redesigned—we have made it consistent with the Emlid Flow interface, removed redundant tabs, and added an exciting dark theme.

Please note, the survey tools from Reach Panel have been deprecated in favor of the Emlid Flow app. So if you are looking for your familiar survey tools, try our upgraded mobile app—Emlid Flow for iOS and Android.

Updated screen views in Emlid Flow

Updated Reach Panel interface

Note that Reach Firmware 30 update is available for the Reach RS and Reach M series receivers.

The full list of changes


  • Compatibility with third-party receivers when Reach is set up as a base
  • RINEX compatibility with third-party post-processing tools
  • IBGE logging preset to contain GPS and GLONASS satellite systems
  • Web interface for Reach Panel and Emlid Flow app
  • Receiver boot time
  • Connection over Bluetooth with Android 12 devices for Reach RS+/RS2/RS2+
  • Battery charging estimation algorithm on RS2/RS2+
  • Support for non-ASCII URLs for NTRIP casters
  • Stability of receivers’ performance


  • The wrong distance in the NTRIP mount point list if there are no coordinates
  • Issues with connecting to Wi-Fi networks
  • Issues with starting logging after firmware upgrade
  • Cases with corrupted raw logs on immediate shutdown
  • Issues when corrections weren’t transmitted over LoRa after booting
  • Cases when Corrections Input or Output settings were changed after reboot
  • Device names starting or ending with a dash symbol—now prohibited
  • Entering base corrections until base coordinates are averaged or set up manually

Stable or dev?

1 Like

I think it is stable version now

This is a stable version.


That’s right, thanks!


I updated one of our M2’s that serves as a CORS for our network and as soon as it rebooted I lost corrections from the RTK network I had been using. I was trying to shoot in it’s new home and while it said connected but it would never start receiving corrections or fix. I rolled it back to stable 29.2? and it immediately had a fix.


…Please note that the Reach Firmware 30 update is available for Reach RS and Reach M series receivers. not for RS2 and M2?

I’m not sure if we are talking about the same thing but we get prompted on the M2 and RS2+. I was able to get it to work on the RS2+ by setting the receiver back to defaults after the update and rebuilding the configuration. I am going to try the same thing with the M2 today or tomorrow.

1 Like

Hi Michael,

If I got everything right, then I have an assumption that this might have happened because of the new restriction added to this release. The correction stream from the base doesn’t start until the base’s coordinates are averaged. If there were no corrections during the period of time averaging, it could be it. If not, it’d be great to see the report from that M2 on the latest stable to investigate it further.

Hi Luis,

This note means that this update isn’t available for Reach RX. Your Reach RS2 and Reach M2 should receive this update just fine!


Hello everyone,

I have noticed that in the average single method it is now possible to enter the height of the instrument, very nice change!. For those with less experience this was causing some confusion.



Hi Bernardo,

Thanks for the feedback! I agree that this feature is very useful.


Excited for this release! The inclusion of height really is a topic that calms the mind to never miss altitudes.
Regarding the connection with an external radio, I realized that when I turned on the device in SERVER mode, it did not present errors, but when I turned on Lora and then switched, sometimes it did not send correction when I changed the correction input.

1 Like

I have 2 Reach RS2 units. The update appears on one unit as available, but not on the other. They are both connected to the same wifi network, and are both running 29.2. They are the same vintage, purchased together from E38. No other issues with this receiver, there is just no update available (it doesn’t see any available beta updates either.) It checks for updates, but does not find any.

No change after multiple restarts of the receiver. What am I doing wrong?

1 Like

Hi @joaovitorlara8,

So to just understand that I get everything correctly, your base doesn’t send the correction messages when you switch to LoRa in the settings? Can you please describe your workflow step-by-step in such a case?

1 Like

Hi Rob,

Welcome to the forum!

Is it possible to connect that receiver to another Wi-Fi network just to check if it gets the update in this case? You may connect it to your mobile phone’s hotspot, for example.

1 Like

I finally got it sorted, but it was strange. I did connect it to my hotspot, and the little red dot next to settings appeared (indicating a update is available), but when I clicked through to actually update, it spun for a few moments and then proudly stated that I was up to date at 29.2.

I switched back to my main wifi, and got the exact same result (little red dot appeared, but then no update actually available.

Switched back to my hotspot, and everything worked. Updated to v30 successfully.

Meanwhile, my second RS2 updated first try with no guff whatsoever. So… shrug, I guess.

does anyone have the new update (30) and noticed that when turning off the phone screen, it loses connection? then you have to restart the Emlid Flow?

Yes, it works. Sometimes he lost signal when switching from Lora to Serial. However, when a configuration (serial) is defined and the device is turned off, the next time the device is turned on, the last settings are maintained. Thus, already connecting the device in Serial, I never had base correction problems or failure in the reception of the Rover signal (even alternating radio/NRIP input corrections)

Hi Rob,

That’s quite strange, I agree. Most likely, there’s an issue with getting a response from the update server over the particular network. I’ll let the devs know about your case.