Navio2 image not working on Raspberry Pi 4

Hi, I recently purchased a Navio2 and followed all the setup instructions, but I can’t get it to boot on my Raspberry Pi 4 board. I’ve tried 2 known working Pi 4 boards but got the same results. Thinking I may have gotten a bad Navio2 I borrowed my friends Pi3 and it boots up no problem.

I thought there was an issue with the new Pi 4 rev 1.5 boards? I couldn’t find much info on the new 1.5 revision besides from:
HiFiBerry: Raspberry Pi 4 1.5 incompatibilitieshttps://www.hifiberry.com/blog/digi2-pro-raspberry-pi-4-1-5-incompatibilities/
and
YouTube: This Is Why I Might Be Done With Raspberry Pi | Rev 1.5 Bootloader Nonsense

I went ahead and built a new Raspbian image and ran “cat /proc/device-tree/model” and both of my Raspberry Pi 4s come up as Model B Rev 1.4.

This is where my Pi 4 is stopping on the emlid-raspbian-20200922.img:
1.0790151 sdhci-pitfm: SDHCI platform and OF driver helper

Any help would be appreciated as Pi’s are very hard to come by these days and I only have ones that seem to not be compatible.

Hi @Citadel-North,

Thanks for reporting!

We have a couple of reports of the issue with booting on Raspberry Pi 4. The bootloader packages of Raspberry Pi OS were changed, and now there can appear some challenges with the correct booting. But our devs have found how to fix that, and we’re currently on the testing stage. Once the updated image is out, I’ll let you know.

There’s a workaround suggested by one of our users which you may try. But I’ve not tested this myself, so I can’t guarantee it’ll work.

Hi @liudmila.slepova, Thanks for the reply. I’m glad to hear there is a new image in the works. If you need I can test it out and provide feedback.

I tried the suggested workaround by replacing the start4x.elf file. The Pi 4 proceeded a lot farther but now the Navio2’s green light turns off and the screen is blank: Navio2 not working with Pi 4 and start4x.elf file - YouTube

Hi @Citadel-North,

Thanks for your offer! We’re not updating the functionality though, this update is only required to tailor some RPi 4 boards. So, we just need to make sure that the image works stable.

I can hardly guide you in this for now, as I’ve not tried it. I assume this workaround doesn’t work properly in all the cases. Let’s wait for the update, then. It should help with this issue.

Hi @liudmila.slepova , is there any update on when the new image will be released?

The documentation on Emlid’s website clearly says the Navio2 should be compatible with a Raspberry Pi 4, but this is not accurately advertised. If the new image is not released soon, can Emlid help setup a return process for boards purchased through official distributors? I think I may switch to a Pixhawk flight controller instead as there seems to be a lack of movement on this.

Hi @Citadel-North,

It’s on the testing stage at the moment. Once it’s out, I’m surely let you know.

Navio2 is compatible with Raspberry Pi 4 boards. The issue with the bootloader came out recently and only for some newly produced RPi 4 boards. It works just fine with older RPi 4 we have in our office, for example.

I understand that this impacted your plans. We’re working on this to make those affected boards working fine again. Since those changes came from the other side, we couldn’t prepare for them beforehand. However, we’re aimed to provide you with the solution.

Hi @Citadel-North,

The image with the update for this issue is out! You can download it using the link from the following guide.

Please let me know how it works for you now.

Hi @liudmila.slepova that’s great news! I’ll try the new image out this weekend and let you know.

Sure thing, thanks! I’ll be waiting for your feedback.

Hi @liudmila.slepova , the image so far is working with the Pi4. Thanks for getting this released :smile: .

2 Likes

Hi @Citadel-North,

I’m glad to hear that :tada: Thanks for your feedback on this!

In case of any other questions, don’t hesitate to let me know.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.