Navio+ Stuck in booting (rainbow screen) (partially-SOLVED)

Hi everyone. I had a problem with my Navio+. I am new at the community, and I want to share a problem I had, and how I “solved” it.
I did all steps in the wiki, to install Navio+, but when I plugged the board to the Raspberry Pi 2 B, it always got stuck at the rainbow screen (which is supposed to last less than a second).
I found several answers in the Raspberry community, mainly the suggest to add a delay (delay_boost=1…N), because they assume that the problem has to do with lack of enough current in the power supply (which is not my case).
I observed that booting the Rberry alone was ok. But with Navio plugged it got frozen. But if I started RBerry, and then when already booted, plug NAVIO, I was able to make it work just fine.
So after many different suggestions from blogs with no result, I decided to only plug voltage cables of NAVIO. I started to add each cable at a time and rebooting, until I found out that the trouble makers were: Pins: 27 and 28, (ID_SD, ID_SC of i2c ID EEPROM). I physically remove the pins from the NAVIO extension connector. And now it works fine.

I used in summary:

  • emlid-raspbian-20160718.img.xz
  • RBPi 2 B
  • Navio +

Did anybody have this problem?