Navio Beta 4 Raspbian Upgrade Issues

@george.staroselskiy I think this one is for you.

Just tried to do…

$ sudo apt-get update && sudo apt-get dist-upgrade

… with Beta4 and many bad things happened. Worked great about two weeks ago. Looks like there is a new kernel update that it does not like? I am really guessing there. Not my thing.


[Edited due to stupidity on my part]


Beta v4 was released a month ago! Could you please elaborate on the issue? There was rcio-dkms package update today. So I’m interested what is wrong exactly?

Sorry! Lost track of Beta Version. I am running Beta4.

I did it yesterday. Last attempt was about 10pm my time. I am seeing reference to raspi kernel header update. All goes well until then. Then I start getting errors about missing distro folders.

@george.staroselskiy Looks like you are active over on the Raspian GitHub repo. Not surprised. Did some searching and it does look like a new kernel was released with 4.4.48? on Feb 15th 2017. I have not done a fresh install since, so not sure if that helps.

Let me know what I can do to help report this issue more helpfully. All I saw last night was a bunch of errors scrolling by during the update. And rather than throw my laptop against the wall I went to bed.

Are you able to log into your Raspberry Pi? It’d be nice to see any kind of error reports. We don’t run stock Raspberry Pi Foundation’s kernels. So the update won’t affect us. I’ll look into the issue tomorrow morning. I’ll try my best but it’s very difficult to track down without the logs :frowning:

With a bit of rest and some deep breaths I am back at it…It will boot and run OK. Did not try to fly it. I run into really big problems when I try to compile drivers for TP Link Archer. No kernel module folder to match since the update goes poorly. The problem seems to stem from your distro being built on 4.4.36 and then Raspbian tries to push kernel update to 4.4.48…

run-parts: executing /etc/kernel/postinst.d/dkms 4.4.48+ /boot/kernel.img
Error! echo
Your kernel headers for kernel 4.4.48+ cannot be found at
/lib/modules/4.4.48+/build or /lib/modules/4.4.48+/source.
Error! echo
Your kernel headers for kernel 4.4.48+ cannot be found at
/lib/modules/4.4.48+/build or /lib/modules/4.4.48+/source.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.4.48+ /boot/kernel.img
run-parts: executing /etc/kernel/postinst.d/process-vmlinuz-rbp 4.4.48+ /boot/kernel.img
find: `/boot/dtb-4.4.48+/': No such file or directory
find: `/boot/dtb-4.4.48+/overlays/': No such file or directory
Aborting due to one or more missing device tree overlays.
run-parts: /etc/kernel/postinst.d/process-vmlinuz-rbp exited with return code 1
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.4.48-v7+ /boot/kernel7.img
run-parts: executing /etc/kernel/postinst.d/dkms 4.4.48-v7+ /boot/kernel7.img
Error! echo
Your kernel headers for kernel 4.4.48-v7+ cannot be found at
/lib/modules/4.4.48-v7+/build or /lib/modules/4.4.48-v7+/source.
Error! echo
Your kernel headers for kernel 4.4.48-v7+ cannot be found at
/lib/modules/4.4.48-v7+/build or /lib/modules/4.4.48-v7+/source.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.4.48-v7+ /boot/kernel7.img
run-parts: executing /etc/kernel/postinst.d/process-vmlinuz-rbp 4.4.48-v7+ /boot/kernel7.img
find: `/boot/dtb-4.4.48-v7+/': No such file or directory
find: `/boot/dtb-4.4.48-v7+/overlays/': No such file or directory
Aborting due to one or more missing device tree overlays.
run-parts: /etc/kernel/postinst.d/process-vmlinuz-rbp exited with return code 1

This can be reproduced every time by:

  1. Load Beta4 to SD
  2. Boot Raspi3 with Beta4
  3. Run sudo apt-get update && sudo apt-get dist-upgrade

So I suspect your distro would need to rebased off new kernel for this to go away? You know FAR better than I do. I can live with just skipping the update for now. Not great but workable for testing.

Here’s what uname -a outputs after update and reboot…

Linux navio 4.4.48-v7+ #964 SMP Mon Feb 13 16:57:51 GMT 2017 armv7l GNU/Linux

Probably not good since we should be seeing your custom kernel.

I am searching for how to pin the kernel version in raspbian to see if that might not help.

Hope that helps.

did a fresh install; after apt-get update/upgrade/dist-upgrade (not before) i get:
sudo ./arducopter-hexa -A udp
Raspberry Pi 2/3 with BCM2709!
LinuxPWM_Sysfs:Unable to open file /sys/class/pwm/pwmchip0/pwm0/duty_cycle: No such file or directory

logs from /var/log/

@panky thanks for testing. i am going to see if i can pin the kernel version and try another update.

will report back shortly.


sudo apt-mark hold linux-image-4.4.36-da925b7-emlid-v7+

Did not work.


sudo apt-mark hold raspberrypi-bootloader

Did not work.

Looks like this might work…

sudo apt-mark hold raspberrypi-kernel

But I can not find it documented anywhere and one of the raspbian update servers is not responding right now so can’t test it fully. It does mark it as on hold and skips it. Just can’t get the update to finish to see if/how bad I just broke it. Figures. Going to have a drink. Or three.

@coby and @panky Guys, I cannot express more that your testing is appreciated a lot. Thank you for your input. I’ll try to get to the bottom of the problem as soon as possible.

You are welcome.

Completed my tests this morning with

sudo apt-mark hold raspberrypi-kernel

update completed with no errors.

TP Link T2U drivers compiled with no errors.

ardupilot service runs and connects fine with mission planner

This very much points to needing to recompile your kernel against the latest raspbian. If that is the case, is that a good move at this point? I am much more interested in stability of your distro over any new features. I guess if there is critical security issues and/or bug fixes in the new kernel it would be prudent.

I think it would also be a huge help to all of us integrating your system in projects with timelines and due dates if we had a bit better idea of your release schedule/roadmap. I, for one, can not continue to work blind. Don’t need anything fancy. Since there is no public repo with issue tracker to monitor, a simple roadmap and more frequent blog post updates would be awesome. I know you are busy with Reach RS, but that also gets to my point - Some of us need to know if you are going to have a project that drops things like Navio dev to the bottom of the list. I don’t argue with your plan, I completely understand prioritizing in a small shop, just need to have an idea of what that plan is so we can plan. Thanks!

Here’s a temporary fix to get back on track if you don’t want to reinstall everything from scratch.

sudo -s apt-get purge raspberrypi-kernel apt-get install --reinstall linux-image-4.4.36-da925b7-emlid-v7+ apt-get install -f cd /usr/src/rcio* make -j5 reboot

Sorry, guys! There’s a lot of dependencies and somehow this one slipped out of my sight. Release will have a proper fix.
Thanks again for the testing.


Thanks for the solution. This does indeed make eventually almost the same. But it’d be better to eliminate the beast in its infancy.

Close enough, but in this particular situation this is not completely true. In theory our kernel updates should’ve been completely orthogonal to the Raspbian Foundation’s but unfortunately somehow this raspberrypi-kernel packaged slipped into the Beta and screwed up the upgrade (I already made it go away in the new image that is going to be shipped soon).

Fair enough. We’ll try to post it more often. I wanted to make it clear that we are not abandoning our users. Thanks a lot for the feedback. Really appreciate it and we’ll try to make the UX more smooth.

Thanks @george.staroselskiy. Glad we could help run this down. I’ll have a copter up to test in the next week. Will report any other issues.

I seriously hope you can find more time for updates and publishing a roadmap. I don’t think any of us can complain about your support as it is very good. But it all seems too reactive. Would like to be able to be more proactive.


I think I may be running into this problem. Just tried to update, it all seemed to go fine but now it doesn’t boot and the arducopter service no where to be found.
When I execute:

I get
Reinstallation of linux-image-4.4.36-da925b7-emlid-v7+ is not possible, it cannot be downloaded.

I realize this thread a few months old but it is the only thing I can find.

This is indeed very valuable! Since then Beta became stable. So I recommend downloading a stable release.