Navio 2 POSHOLD crash with log

Well just use a regulated Ubec

Morning Emlid,

OK so completed my test bed scratch built yesterday.

As you can see I did exactly what Tatiana instructed. Nothing attached to the USB ports and power is only achieved via the servo rails.

I did 3 flights yesterday. On the second and last flight I performed Autotune. Will do 7 more flights like this and report back if I observe any anomalies.

After 10 flights total I will add the Usb adapter to the drone. And continue test.

1 Like

Hi Barry,

First, I’d like to ask you to raise the GNSS antenna and locate it on a ground plane. A ground plane should be made from a conductive material and be no less than 70 x 70 mm.

Check out this article describing how to set up the antenna for more info.

Also, please share logs from these flights so we can look into them.

log_16_2019-8-12-11-51-54.bin (9.7 MB)

OK the log is attached. Question. Is the groundplane really neccesare for the navio 2 Gps. I do not have any interference or GPS problems with it mounted like that?

Hi Barry,

The attached log is the one from latest crash, not from recent flight. The GPS data was quite good.

Oops. Fixed now thank you Marc.

log_1_2019-8-12-20-42-45.bin (8.2 MB)

Log for today

I actually got really good results out of my Quad today.

This hover was done in 15 knots of wind and in poshold it just kept its position like it was glued in the sky.

Then decided to do a range test using just the Raspberry pi 3 + onboard wifi and managed to push to 200 meters. So really impressed with my setup at the moment.

Then decided to do an Auto mission and despite the wind it just stayed glued to the track like it was on rails.

OK people from Emlid.

Here is the crashlog we have all been waiting for. 10 flights without any peripheral attached to the USB ports and flights were beautiful.

Then this afternoon I attached my USB Wifi range extender and halfway through the flight it did exactly the same as it did before. All of a sudden roll to the right and crashed.

log_1_2019-8-14-13-39-03.bin (3.2 MB)

So how do we now test if it’s a power issue or a driver issue as Tridge from ArduPilot suggested

2019-08-14_14-20-09[1].tlog (1.6 MB)

HELOOO EMLID, Any body there???

Hi @Barry_Bolton,

We’re currently looking into your logs.

@Barry_Bolton,

There are 2 reasons why Wi-Fi module connection might provoke such an issue:

  1. Power supply. This module might consume too much power, for example, while increasing the radio signal power. In this case, you should use a USB hub with an external power supply to resolve it. Something like this one:

You should connect:

  • Micro-USB to Wi-Fi module
  • Middle USB plug to RPi
  • Upper USB plug to power
  1. Wi-Fi module and RPi incompatibility. It’s possible that RPi might conflict with this module. Could you please specify what the RPi model do you use?

I’d recommend checking the power supply option first.

https://www.pishop.co.za/store/wireless/wifi-dongle---ultra-long-range-high-gain-w-5dbi-antenna_1044

https://www.pishop.co.za/store/hackable-naked-7-port-usb-hub-uk-5v-25a?keyword=usb&category_id=0

OK so now I have installed this powered USB board to the system. So the USB wifi adapted plugs in to the powered USB adapter and then the USB adapted obviously connects to the Pi. Will test flight in a little while. The USB board has been modified so that it does not provide backpower to the Pi

Hi Barry,

Could you please share a little more photos of RPi and Wi-Fi module to this board connection so we can check that it’s correct?

I’d also highly recommend raising an antenna and placing it on a ground plane as I suggested above:

OK will add some photos.

I just returned from 4 flights and it flew really well and now anomalies with the current setup.

Please share logs from these flights as well.

log_4_2019-8-18-20-19-05.bin (2.7 MB)