Mapit GIS doesn't show correct status anymore

Topic says it all. Mapit GIS doesn’t show the correct status anymore. It’s stuck on GPS even thought I have Fix in Reachview. It’s pretty annoying to jump between apps to see if I still have fix or not.

is this AFTER recent update of ReachView or something?

Or a recent update of MapIt?

Are your settings in MapIt GIS correct for External GNSS > Direct Connection to External GNSS to your ROVER?

Still good bluetooth connection to your external GNSS unit? Or even TCP?

After the Reachview 2.14.0 update. It worked before but now it’s stuck on GPS. Good Bluetooth connection to Reach RS. I’m able to survey just fine but that status not showing right is annoying. All the DOP’s and everyhting else is recorded to logs but fix-status is always GPS. Even the stakeout function in Mapit is working properly.
There was an update to Mapit few days back and I haven’t used my units after that until today. Updated both units to from 2.13.2 to 2.14.0 today and went out to take a survey and noticed that the status doesn’t change.

Oh no.

Maybe someone can verify if the previous version of Mapit with ReachView 2.14.0 works so you can rule out latest reachview update or if latest reachvew update is the problem?

Wonder if possible to go back a version of Mapit?

Doesnt work on 2.13.0 either

So maybe fault at Mapit?

If TS had a working mapit with version 2.13.2 before update, i would think its a mapit issue

Wonder if this Mapit GIS change broke it?
CHANGE: The app should now work properly with Lefebure NTRIP Client when it’s set as a mock location provider.

V6.5.1 July 30, 2018

Maybe check the mock setting in android?

I am not condoning this at all, but a quick google search of Mapit APK turned this up of the prior versions:

It’s one of those trust / security things and up to you.

I’d check the mock setting in android first or hold off until a solution from developer or better yet ask for prior version from developer and turn off auto update for this app.

Lefebure Ntrip Client shows the correct solution but Mapit still shows GPS. So it seems that the Mapit update broke something. I’ll have to contact developer and wait for an update

I agree. Something is wrong with Mapit GIS. It shows GPS as you state even with external connection.

Maybe in the meantime use Lefebure Ntrip Client with mock enabled for that, but external gnss OFF in mapit gis?

Fix one thing break another… usually something major. : /

Ps. I emailed them also.

Lefebure shows correct solution in app but in Mapit it also shows just GPS. So it doesnt work either. Well just have to jump between apps atm and wait for an update

If you also email them, see if they can provide an official prior version APK for now?

Hello Jaakko,
MapIt GIS got back to me with their email questions. I will message you the email I received and maybe you can respond to them with the immediate problem that is affecting your workflow currently and maybe they can help quicker!

I sent NMEA logs to Mapit and just got the following email. So it seem that this is getting fixed soon :slight_smile:

Hi Jaakko, The NMEA looks fine. I think I have found the bug – in terms of accuracy, RMS data etc. everything is fine – is just the Quality field which currently shows always GPS.

_ _

I will do more testing and get this rectified in the next update of the app – possibly by the end of August.


Hopefully they are getting it fixed soon. ; )

Maybe fixed? : )

FIX: Problem with Export to PostgreSQL when attribute name or attribute value contained ” or ‘ character.
FIX: On some devices there was a problem with saving feature when vertex was moved or removed manually during tracking.
FIX: Position quality was always displayed as GPS even though e.g. RTK-Float was used.
CHANGE: When HRMS is available from external GNSS – it is now always used to set location accuracy.
CHANGE: SXblue GNSS receivers are now supported when latest SXblue ToolBox application is set as Mock Location Provider.

I can confirm that this has been fixed. Just tested it out and it seems to work properly now :+1:


This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.